Playmaker Forum

Playmaker Help & Tips => iOS Help => Topic started by: HaraldsVeiss on September 26, 2015, 03:44:32 PM

Title: PlayMaker Unity 2d prefab on Unity 5.2.x not working... [CLOSED]
Post by: HaraldsVeiss on September 26, 2015, 03:44:32 PM
Hello!

It seems that on Unity 5.2.x PlayMaker Unity 2d prefab loses the FSM component and there for problems arise.

Please help!

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: dudebxl on September 26, 2015, 03:57:11 PM
+1

just happened to me for 2d proxy + ugui proxy.

Unity 5.1.2f1
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: dudebxl on September 27, 2015, 01:28:19 AM
and i still can't get it to work after reinstalling everything nor will it work when i copy prefab from another project.

I am bit lost here..  :o

edit: now get this error when opening PlayMakerUnity2D: Component MonoBehaviour could not be loaded when loading game object. Cleaning up!
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on September 27, 2015, 01:31:09 AM
Hi!

Yes I tried that same things, not helping me either. I am a bit lost too, also its getting a bit urgent now to get this working. :/

I hope playMaker developers gets on top of this problem soon.

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: dudebxl on September 27, 2015, 01:59:39 AM
maybe a temp solution;

I got the proxy to work again by adding an empty fsm to them.
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on September 27, 2015, 02:23:50 AM
Hi,

Thank you that got rid of the errors. Still I hope this will be updated soon.

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: jeanfabre on September 29, 2015, 01:55:56 AM
Hi,

 uhm, I'll try to repro this and provide a fix. Thanks for reporting.

 Bye,

 Jean
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on September 29, 2015, 03:42:58 AM
Hi,

Thank you. Will be waiting.

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: jeanfabre on October 08, 2015, 05:39:49 AM
Hi,

 Haven't forgot, but Slightly running behind, so made a trello task (https://trello.com/c/xU9kNnSX/149-2d-support-update-on-unity-5-2)

Thanks for your patience.

 Bye,

 Jean
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on October 12, 2015, 12:45:10 AM
Hey!

No problem, the suggestion to add an empty FSM to the prefab helped with the errors and everything seems to be working for now.

But anyway it would be nice to know why is that happening. :)

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: jeanfabre on October 13, 2015, 05:16:34 AM
Hi,

 I am not sure I get it.

-- Are you sure you are putting "PlayMaker Unity 2D" prefab from "PlayMaker Unity 2D/Resources" in your scene?

-- Are you sure you put a "PlayMaker Unity 2d proxy" on your 2d rigidbodies and 2d colliders?

this prefab is needed for proper operation. I may remove it, cause know I have better routines to avoid the need of this prefab, but still, the current solution works as far as I can see.


Bye,

 Jean
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on October 15, 2015, 09:38:28 AM
Hey!

Yes I am doing that, but it seems that there is something wrong in my project. Recently I made a fresh project did exactly the same thing as in my previous project and it is working.

Sorry for bothering you.

Best,
Haralds
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: jeanfabre on October 16, 2015, 04:30:18 AM
Hi,

 you are not bothering. It's ok and necessary to share your issues and problems, what ever they are.

So let us know if you can't get it to work :)

Bye,

 Jean
Title: Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
Post by: HaraldsVeiss on October 16, 2015, 05:02:22 AM
Hey!

Thank you! I will let you know if there will be any problems!

Have a great day!

Best,
Haralds