Playmaker Forum

Playmaker News => Playmaker Announcements => Topic started by: Alex Chouls on January 28, 2016, 11:24:57 AM

Title: Unity 5.3 Compatibility
Post by: Alex Chouls on January 28, 2016, 11:24:57 AM
IMPORTANT: Unity 5.3 users should install the 1.8.0 beta.
There are known issues with 1.7.8.4 and Unity 5.3 that are fixed in 1.8.

1.8 has been in beta for a while and is stable. We just wanted to release it as a public beta since it's a big update. It will become the official version very soon.

Import the latest version from the store, then install 1.8.0 from the Welcome Screen.

If the Welcome Screen doesn't open automatically you can find it here:
MainMenu > PlayMaker > Welcome Screen.

You can also find the PlayMaker.1.8.0.unitypackage in Assets\PlayMaker\Editor\Install.

As always, BACKUP your projects before updating! Projects saved with 1.8 cannot be opened in older versions of PlayMaker!
Title: Re: Unity 5.3 Compatibility
Post by: Alex Chouls on February 06, 2016, 10:50:42 AM
If you get this error in Unity 5.3.2 when pressing play in the editor:

Code: [Select]
InvalidOperationException: This cannot be used during play mode.
UnityEditor.SceneManagement.EditorSceneManager.MarkSceneDirty (Scene scene)

Please import the attached unitypackage. This patch will be in the next update.
Title: Re: Unity 5.3 Compatibility
Post by: jason statham on March 04, 2016, 05:18:57 AM
Thanks it works!! ;)
Title: Re: Unity 5.3 Compatibility
Post by: doppelmonster on June 12, 2016, 11:07:57 PM
Hi Alex,
i just downloaded 1.81. Does that mean its final? I think you should create a upgrade guide for projects created with 1.7x. Which is about incompatibility, solutions and workarounds.
Or is there already some info I am misssing?

Thanks,
Matthias
Title: Re: Unity 5.3 Compatibility
Post by: jeanfabre on June 13, 2016, 03:35:47 AM
Hi,

Yes, 1.8.1 is final.

 The upgrade guide is available within the Update checker editor window that is launched when you installed the package from the Asset store.

 The upgrade mainly affects new sets of actions that where previously available on the wiki and Ecosystem, now they are officialy distributed. This should not change or alter any of your existing projects, so the guide is really about cleaning up your project, however, since the guid are kept, even without cleaning, up things should go smoothly.

There is no know incompatibilities as far as I know.

 Let us know if there is some hickups, we'll assits.

 Always backup before upgrading is the most important part of a safe transition :)

Bye,

 Jean

Bye,

 Jean
Title: Re: Unity 5.3 Compatibility
Post by: Dan on July 28, 2016, 08:33:07 PM
Hello,

I'm running 1.8.0 and when I run updater it states no updates needed. How do I get the most recent 1.8.1?

Thanks


5.3.5f1 Personal Edition
Title: Re: Unity 5.3 Compatibility
Post by: aa_lique on July 31, 2016, 10:36:45 AM
Hi Alex
Are both 1.8.0 and 1.8.1 compatible for 5.4?
Thanks
Angelique
Title: Re: Unity 5.3 Compatibility
Post by: paul.harden on August 02, 2016, 11:56:04 AM
Hi,
I've just installed playmaker in a new 5.3.5 project and apparently a number of network actions are broken.
Any Clues?
Title: Re: Unity 5.3 Compatibility
Post by: jeanfabre on August 29, 2016, 04:38:15 AM
Hi,

 It's best to delete all networking actions, they are obsolete. The next version of PlayMaker should enforce better isolation of obsolete api for networking.

 Bye,

 Jean
Title: Re: Unity 5.3 Compatibility
Post by: paul.harden on August 29, 2016, 05:05:19 AM
ok, thanks!
Title: Re: Unity 5.3 Compatibility
Post by: Sharm on October 05, 2016, 06:10:06 AM
hello 8) 8) 8) 8) 8)