Playmaker Forum

Bug Reporting => Playmaker Bug Reporting => Topic started by: krmko on October 23, 2017, 01:34:48 PM

Title: Action Browser Not Working [SOLVED]
Post by: krmko on October 23, 2017, 01:34:48 PM
(https://s26.postimg.org/qoqrkqbrd/screenshot_77.png)

Playmaker 1.8.3
Unity 5.6.3f1 personal

I opened the action browser, started typing "bool" to filter out an action, but everything disappears and i can't click anything. I get this error:

Code: [Select]
InvalidCastException: Cannot cast from source type to destination type.
OnAnimatorUpdateActionEditorBase.EditEveryFrameField () (at Assets/PlayMaker/Actions/Animator/Editor/BaseClasses/OnAnimatorUpdateActionEditorBase.cs:18)
GetAnimatorBoolActionEditor.OnGUI () (at Assets/PlayMaker/Actions/Animator/Editor/GetAnimatorBoolActionEditor.cs:19)
HutongGames.PlayMakerEditor.ActionEditor.OnGUI (HutongGames.PlayMaker.FsmStateAction action) (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionEditor.cs:196)
HutongGames.PlayMakerEditor.ActionSelector.DoSelectedActionPreview () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:589)
HutongGames.PlayMakerEditor.ActionSelector.DoBottomPanel () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:546)
HutongGames.PlayMakerEditor.ActionSelector.DoGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:158)
HutongGames.PlayMakerEditor.BaseEditorWindow.OnGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/BaseEditorWindow.cs:72)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

I tried restarting Unity, opening Action Browser in another FSM, but nothing.

Any idea how to solve it? It's screwed up and i need to work. I see this guy had the same problem:

http://hutonggames.com/playmakerforum/index.php?topic=14137.msg71250#msg71250

Not really into reinstalling Playmaker if that's the solution.
Title: Re: Action Browser Not Working
Post by: Alex Chouls on October 23, 2017, 01:47:33 PM
Hi, when did it stop working? Did you import something new, e.g., custom actions?
Did you try unchecking Preview? Obviously not a fix, but might let you keep working while we figure out the problem.

If you can send the project, PM me and I'll take a look at it.
Title: Re: Action Browser Not Working
Post by: djaydino on October 23, 2017, 03:34:57 PM
Hi,
I had this also before on 1.8.3
You can try if youca n close the window

Or try the latest version from playmaker :

Make a backup and update to 1.8.4 (or latest if there is a newer one) this should be resolved on later versions.
Title: Re: Action Browser Not Working
Post by: krmko on October 23, 2017, 10:46:08 PM
Hi Jean,

obviously, i can't access the action panel to turn off the preview. I'm backing up stuff, i'll try upgrading, it was about time anyway.
Title: Re: Action Browser Not Working [SOLVED]
Post by: krmko on October 23, 2017, 11:11:45 PM
Updated to 1.8.5, all's well now, thanks guys.