Playmaker Forum

Playmaker Help & Tips => Playmaker Help => Topic started by: zeeawk on March 11, 2018, 09:41:28 AM

Title: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: zeeawk on March 11, 2018, 09:41:28 AM
Installed playmaker, installed eco system. Playmaker menu item shows up but only shows "install playmaker" and "tools".
Launching 2017.2.0f2 works fine.
Title: Re: Playmaker broken with unity 2018.1+
Post by: djaydino on March 11, 2018, 10:37:48 AM
Hi.
I believe 2018 is still in beta.

You can request to Alex (http://hutonggames.com/playmakerforum/index.php?action=profile;u=3) or Jean (http://hutonggames.com/playmakerforum/index.php?action=profile;u=33) to join playmaker beta to get playmakers beta version.
Title: Re: Playmaker broken with unity 2018.1+
Post by: Alex Chouls on March 11, 2018, 12:13:50 PM
To work with the 2018.1 beta please delete the Assets\Playmaker\Actions\ProceduralMaterial folder.

Unity removed built-in support for Substance materials in the 2018.1 beta, and Allegorithmic has yet to release their plugins, so these actions are not currently supported in 2018.1.

Note we can't always guarantee that Playmaker will work with Unity beta versions. But we appreciate you letting us know when stuff breaks!
Title: Re: Playmaker broken with unity 2018.1+
Post by: zeeawk on March 13, 2018, 11:41:15 AM
thanks!
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: Plancksize on April 28, 2018, 05:59:51 PM
Looks like the new 2018.2.0.b1 changed something more vital for Playmaker. Right now, after adding it to a project it just outputs a bunch of errors, finishing with a:
"Unloading broken assembly Assets/Plugins/PlayMaker/PlayMaker.dll, this assembly can cause crashes in the runtime"

The editor window will also open as blank while outputting several errors. I don't think there's an easy solution like the one for 2018.1, right?
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: kavery on May 03, 2018, 07:31:59 AM
Having difficulty getting 2018 non beta working. Trying to update a project at work which was created using the latest 2017. After deleting the procedural material folder I get an endless list of playmaker errors. I delete (ie arraymaker stuff), then new errors.

Playmaker 1.8.9 was previously installed for this project. But Playmaker menu tab is not there.
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: blackant on May 03, 2018, 07:39:27 AM
i deleted the folder playmaker utils cause there was a problem related to FSMVar. after that, you can get back the main menu and reinstall playmaker correctly.

after this you'll have to delete Procedural folder to have a clean install
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: kavery on May 03, 2018, 08:35:21 AM
Thanks for the fast reply blackant, after doing that plus deleting arraymaker folder and custom actions folder the menu appeared while the project was still open. Runs now.
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: miguelfanclub on May 05, 2018, 05:38:55 AM
That means no array maker in 2018?
Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: djaydino on May 06, 2018, 04:39:55 AM
Hi,
Array maker Should work fine,
Tested on U2018.1 and playmaker 1.9.0 Beta.

Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: GaTechGrad on May 08, 2018, 03:55:42 AM
All of my PlayMaker projects appeared to be broken after updating Unity to 2018.1.0f2 (release version).  I also tried making a blank Unity project, imported PlayMaker from the asset store, and still received errors.

Using the suggestion to delete Assets\Playmaker\Actions\ProceduralMaterial seemed to make the errors go away for one of my projects, and got things back to a somewhat workable state.  I had to pull PlayMakerGlobals.asset from my source code repository and put in it Assets\PlayMaker\Resources to get the globals working again.  A couple of the parameters in the PlayMaker GUI had to be redone, but it wasn't too big of a problem.

On other project, I just had to delete the ProceduralMaterial folder and it was working again.

Title: Re: Playmaker broken with unity 2018.1+ [SOLVED]
Post by: jeanfabre on May 09, 2018, 01:03:53 AM
Hi,

 I just tested and it's fine,can you delete the offending actions until all errors are gone and tell me what version of PlayMaker you have?

 Bye,

 Jean