Playmaker Forum

Playmaker Help & Tips => Windows Phone 8 Help => Topic started by: elmoeduardo on October 19, 2014, 05:03:59 PM

Title: Invalid Cast Exception on deployment
Post by: elmoeduardo on October 19, 2014, 05:03:59 PM
Hello, first post over here.
Im using playmaker 1.7.7.f6 Windows Phone 8 Version with almost all the possible addons (playmaker 2D, windows phone, mecanim, itween etc) latest version on all of them. Making the deployment to a device (Lumia 1520) is throwing an invalid cast exception on CallMethod.cs function DoMethodCall() I think that the exception is happening on the storeResult.SetValue(result); line. I have attached a screenshot of the VS solution. Upgrading the project to WP8.1 does not solve the issue.
Any help is greatly appreciated, if you need more info please let me know.
Thanks!
(http://i.imgur.com/CwcDyXF.jpg)
Title: Re: Invalid Cast Exception on deployment
Post by: Alex Chouls on October 21, 2014, 08:47:22 PM
Did you try the Call Method update here:
http://hutonggames.com/playmakerforum/index.php?topic=7526.msg36344#msg36344

WP8 support should be better in the next Playmaker update, I'll PM you about access to the beta...
Title: Re: Invalid Cast Exception on deployment
Post by: mgants on May 22, 2015, 10:31:36 AM
Hi,

I am running into the exact same problem.
I also tried the Call Method update, but no luck.

Does the latest version of PlayMaker on the asset store (1.7.8.3) fix the issue or is there a beta still in progress?

Regarding versions, I noticed that after applying the Windows Phone 8 addon, the version of PlayMaker.dll is reported as 1.7.7.6. Is there a newer one available?

Hmm, just found this:
http://hutonggames.com/playmakerforum/index.php?topic=9964.0

...wondering my team didn't upgrade PlayMaker the right way?
Will poke at it some more to see. Any info you can provide would be helpful.

Update:
- Those instructions are for Unity 5, we are not there yet, still on Unity 4.6.4.f1.

Any chance there are PlayMaker Windows Phone 8 fixes for Unity 4.6.4f1, or do we need to go to Unity 5?

Thanks!

mg