playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MajorIdea

Pages: [1] 2 3 ... 9
1
That's the latest. Been using it with the latest version of unity with no real issues.

2
Playmaker Help / Re: Cinemachine Package Errors
« on: September 24, 2018, 02:01:48 PM »
Yep. Had to comment a bit more but I can now use the package. Hope its nothing important xD

Code: [Select]
_brain = this.GetComponent<CinemachineBrain> ();
                if (_brain != null) {
                    _brain.m_CameraActivatedEvent.AddListener(HandleCameraActivatedAction);
                    _brain.m_CameraCutEvent.AddListener(HandleCameraCutEventAction);
                }

3
Playmaker Help / Re: Cinemachine Package Errors
« on: September 21, 2018, 09:53:25 AM »
Still not working :\



Not sure what you mean by "but you need to switch it accordingly to your unity version"

I'm using the Cinemachine Package Manager version 2.2.7 and the Ecosystem Playmaker Cinemachine actions v1.2.3


4
Playmaker Help / Re: Cinemachine Package Errors
« on: September 21, 2018, 09:31:25 AM »
Thanks Jean,

When I got the error with the Package Manager version I came here and seeing the answers switched to the asset store version (version 2.1.10).

I'll switch back to the newer one and see if I can make it work :)

5
Playmaker Help / Cinemachine Package Errors [SOLVED]
« on: September 20, 2018, 08:07:44 AM »
Hi, I've been trying to get cinemachine to work with Playmaker and looking at other threads I understand there's no support yet for the new version in the package manager, so we should use the asset store version.

According to the other threads that seems to be the answer but it's not working.

I'm using the latest Unity 2018.2.8f1 and I wonder if that's the issue since the Playmaker 1.9.0p4 has no 2018 version (never been an issue before).



Any ideas?
Thanks

6
The only way I can think of it happening is if you have an FSM open with a ton of states which just naturally slows down the editor. I usually try to break big FSMs into smaller ones for this reason and because its usually better for organization imo. If they're a bunch of small FSMs I dont see why it's happening.

Although maybe you're using OnTriggerStay? That could slow things down since it's pretty expensive.

7
Playmaker Help / Re: Aligning Direction Vectors
« on: July 13, 2018, 07:24:57 AM »
Man, I thought that would totally work. It's a great idea but it seems that wont work with a action using Forwards (like QuaternionLookRotation or SmoothLookAtDirection).

I can swap and invert the values and have it change it's behaviour but it doesn't seem to change the fact that it's using Forwards.



It's not easy to see but even swapping the Y and Z values, the blue forward vector is still the one mirroring the circular motion of the Up green vector on the right box.  ???

8
Playmaker Help / Re: Aligning Direction Vectors
« on: July 12, 2018, 01:22:29 PM »
Quaternion Look Rotation seems to give better results (Creates a rotation that looks along forward with the the head upwards along upwards.) but it seems there's no way of using anything but the forward.

Changing the Up Vector seems like it should do the trick but nothing.



Is there an operation that can be made to use the up vector instead of forward or is that outside of what can be made with existing playmaker actions?

9
Playmaker Help / Re: is it safe to use \ or / in fsm variable names?
« on: July 12, 2018, 11:55:23 AM »
Yep, I use it often to make things better organized.

10
Playmaker Help / Aligning Direction Vectors
« on: July 12, 2018, 11:09:39 AM »
I'm trying to make the Up direction on the left box mirror the up direction of the right.



It's not about mirroring the rotation transform (would just use a get/set rotation) but aligning the direction so this can be used to align the box with any direction (like a surface normal)

Quaternion.FromToRotation seems to be the thing to use  and I think I'm using the playmaker equivalent https://hutonggames.fogbugz.com/default.asp?W1330 but its not working.

Any ideas?

11
Sure: https://imgur.com/pInqWe3

That was the screenshot of the layout when it was working, but after changing reverting to unitys default and replicating it was broken again. It does that a lot. Starts and stops for no reason I can find.

I do use a Get Axis Vector in one of the FSMs

Windows 10

12
Sorry, just got back from vacations. Upgraded to 1.9.0P2 and it's broken still. Last time probably wasn't fixed after all but like VVGM it worked for a time. This happens both on my laptop (single screen) and Desktop (second monitor). Resetting editor layout did nothing. I could send a test project with the issue if that helps.

I also noticed that when I create a new empty FSM it works fine. I scroll on the empty state view with and without clicking on it and its ok. But when I add an action it breaks and stays broken even if I remove the action and am back to an empty state.

After resetting the editor and rearranging the layout back to my liking It started working again. Thinking I came across a setup that worked I took a screenshot and checked if it worked another way. I didn't find any and going back to the one that worked, it didn't work anymore... gah!

13
I just upgraded playmaker to version 1.9.0 Patch 1 and this issue seems to be fixed :)

14
I did. It seems to be less consistent than I thought. I've tried to figure out what makes it work and what breaks it but no concrete ideas yet. Here's some oddities:

Sometimes when I reorder the actions it starts working. But doing it again will break it. Thinking it was a bad action on top I delete it and it's still broken: https://gfycat.com/FatalHomelyJunebug

It also works when there's a warning about a missing component: https://gfycat.com/FormalCarefulArcticduck

Weird  ???

Pages: [1] 2 3 ... 9