playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MajorIdea

Pages: [1] 2 3 ... 8
1
Sure: https://imgur.com/pInqWe3

That was the screenshot of the layout when it was working, but after changing reverting to unitys default and replicating it was broken again. It does that a lot. Starts and stops for no reason I can find.

I do use a Get Axis Vector in one of the FSMs

Windows 10

2
Sorry, just got back from vacations. Upgraded to 1.9.0P2 and it's broken still. Last time probably wasn't fixed after all but like VVGM it worked for a time. This happens both on my laptop (single screen) and Desktop (second monitor). Resetting editor layout did nothing. I could send a test project with the issue if that helps.

I also noticed that when I create a new empty FSM it works fine. I scroll on the empty state view with and without clicking on it and its ok. But when I add an action it breaks and stays broken even if I remove the action and am back to an empty state.

After resetting the editor and rearranging the layout back to my liking It started working again. Thinking I came across a setup that worked I took a screenshot and checked if it worked another way. I didn't find any and going back to the one that worked, it didn't work anymore... gah!

3
I just upgraded playmaker to version 1.9.0 Patch 1 and this issue seems to be fixed :)

4
I did. It seems to be less consistent than I thought. I've tried to figure out what makes it work and what breaks it but no concrete ideas yet. Here's some oddities:

Sometimes when I reorder the actions it starts working. But doing it again will break it. Thinking it was a bad action on top I delete it and it's still broken: https://gfycat.com/FatalHomelyJunebug

It also works when there's a warning about a missing component: https://gfycat.com/FormalCarefulArcticduck

Weird  ???

6
When updating to unity 2018.1.0.f2 and playmaker 1.9.0.f5 I noticed that whenever I scroll the mouse wheel, even with the mouse on top of the state view, it always scrolls the graphview instead. It seems to work correctly on the preferences view.

I've looked into the settings to see if it was a new default but cant find anything. Besides, sometimes it works correctly but 90% of the time it doesn't. It's a bit maddening trying to work like this.

Is this a known issue?

7
Action Requests / Re: Material GetPropertyBlock[SOLVED]
« on: November 09, 2017, 07:10:59 AM »
Just made a quick test and it totally works!

The getters would be useful. For example: using this to fade out trees between the camera and player animating the alpha. With the "Get" we can get the current alpha and smoothly interpolate from the current value, rather than having cases where the tree is in the middle of fading out when it detects its no longer in the way and jumps to going from full transparency to full opacity.

Thanks Jean!

Quick test:

8
Action Requests / Material GetPropertyBlock[SOLVED]
« on: November 03, 2017, 03:10:02 PM »
I was looking for a better alternative to material instances and came across this:

http://thomasmountainborn.com/2016/05/25/materialpropertyblocks/

It's a really powerful feature but not very well known.

I tried to find access to it via the get property action of the mesh renderer component but doesn't seem to be there.

It would be wonderful to have those GetPropertyBlock and SetPropertyBlock actions.

Cheers!

9
Playmaker Help / Re: Material Instance
« on: November 03, 2017, 03:01:15 PM »
That totally works.

Although if doesn't work if I set the material to none, has to be empty.

Thanks!

10
Playmaker Help / Material Instance [SOLVED]
« on: October 30, 2017, 01:52:27 PM »
Hey,

Isn't there an action like a Set Material Renderer Color or Float?

I'm trying to fade objects like trees between the camera and the player and if I do a Set Material Float and change the opacity it changes all the trees instead of the ones detected.

I noticed for example the Dotween action "Color Renderer To" creates an instance of the material but I cant seem to find another way to do that. Is there?

11
Feature Requests / Decouple Graph View
« on: October 23, 2017, 12:25:48 PM »
Hi!

I couldn't find this suggestion so here it is:

It would be nice to decouple the graph view from the FSM/State/Events/Variables tab.

When I want to see the state actions as I test something, especially when there are a lot of them or I want to check the debug values, I often need to either pause and scroll down to see the debug value or have a gigantic playmaker editor window filling most of the screen just so I can see more actions.

The "Hide Unused" definitely helps but still, would be nice :)

Have a nice day!

12
I think the "Audio Stop" action should work.
Destroying the FSM wouldn't stop it - it tells the Audio Source component of the Game Object what to do so if you tell it to play sound and then kill the messenger (so to speak) it still got the message.

13
Playmaker Tips & Tricks / Re: Improving The Workflow
« on: October 17, 2017, 08:26:22 AM »
This is really good. Thanks a lot!

One question though - I don't know how if this is true but isn't placing a bunch of empty states as labels going to affect editor performance? It usually shows a warning when we have too many states in an FSM.

14
Playmaker Help / Re: Convert normalized vector (heading) to rotation?
« on: October 15, 2017, 11:48:04 AM »
I do something similar with a "Smooth Look At Direction" action and plug the target's velocity into it.

15
Feature Requests / Colored Actions in State Tab
« on: October 15, 2017, 10:25:25 AM »
Would be nice to visually group actions in the state tab for better readability of more complex states!

Something like this:



Keep up the great work!

Pages: [1] 2 3 ... 8