playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - HaraldsVeiss

Pages: [1] 2 3 ... 5
1
Android Help / Re: Android Native
« on: December 12, 2015, 10:09:05 AM »
Hello!

Thank you for your help!

I noobed out big time, I didn't notice that in Google Developer console my uploaded version was one version lower than the one on my device. Since the APK version numbers didn't match it was causing errors on log in and IAP.

Thank you for taking the time and helping out!

Have a great day!

Haralds

2
Android Help / Re: Android Native
« on: December 11, 2015, 03:15:02 PM »
Hey,

Thank you, I have contacted their support, but haven't got a definitive answer yet, that why I am starting to ask around forums.

Thank you for your input!

Best!

3
Android Help / Android Native [SOLVED]
« on: December 11, 2015, 12:07:30 PM »
Hello,

I have a problem with Android Native plugin using Playmaker actions. I have the latest Android Native version.

1) My game sometimes gets stuck on logging in the Google Play account. I have to restart the game to get it to sign in. Sometimes even the restart doesn't help and I have to restart again.

2) In app purchase is failing every time I trie to purchase it. It doesn't even open the dialog box for purchase where you can see the price and so on.

I have checked the base 64 key, and all the IDs. I also have everything updated to the latest versions, so that should be a problem.

I am testing the Android game in Beta on Google Play developer console. I am In beta I haven't submitted any build to production phase, could that be a problem?

Just a final note - in Google Play developer console I have everything activated.

Has some one experienced these problems with this plugin?

Thank you for taking the time and reading this!

Let me know if you need more info!

Best,
Haralds

4
iOS Help / Re: gamecenter highscore/leaderboard setup
« on: November 24, 2015, 04:19:03 AM »
Hey Nepomuk,

Basic set up:

Before setting up the actions make sure that you have right app ID in the Stans Assets settings.

You are right to first initiate the GC by using ISN_Game Center Init. After it has been initiated I usually use finished event and float it in to an empty state and leave it be.

Leaderboard:

Go to your iTunesConnect account and add a leaderboard for your game, iTC will generate a leaderboard ID witch you will have to use in your action ISN_Submit score.

Make sure that when you are trying to submit score that you are checking if this is the best score player has and than call the ISN_Submit score action.

I usually like to make a Score Manager that checks after a play session or level if the score is better than the players current best score, and if it is better than I send an event to change the best score in game and send the score to Leaderboard by using ISN_Submit score action.

(I usually put best score in a global int so it would be easy to access from anywhere in the game. Add that Global int to the ISN_Submit score action)

Hope that this makes sense, let me know if I need to explain more.

Best,
Haralds




5
General Discussion / Re: Urgent, help! Basic topics.
« on: November 24, 2015, 03:56:30 AM »
Hey Yuki,

As I understand than you can't get the actions to fire when your player is colliding with your traps and pickups.

Here are some things to check:

1. Make sure that your player has Rigidbody attacked to it, so it can detect collisions and/or triggers.

2. Check if the pick ups, traps and player has proper tags.

3. Double check if pickup colliders (and other props) are marked as trigger.

4.And last thing to make sure is that everything is set up right with Playmaker action Trigger event. Check the tag in the action and make sure that the right event is firing.

After you check all these things it should be working!

If you have any questions let me know!

Best,
Haralds

6
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: October 16, 2015, 05:02:22 AM »
Hey!

Thank you! I will let you know if there will be any problems!

Have a great day!

Best,
Haralds

7
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: October 15, 2015, 09:38:28 AM »
Hey!

Yes I am doing that, but it seems that there is something wrong in my project. Recently I made a fresh project did exactly the same thing as in my previous project and it is working.

Sorry for bothering you.

Best,
Haralds

8
iOS Help / Re: Chartboost interstitial ads. [CLOSED]
« on: October 12, 2015, 01:02:03 AM »
Hey!

I ditched the chartboost actions and ended up using Heyzap with code.

No help needed any more! :)

Best,
Haralds

9
iOS Help / Re: Ads using PlayMaker actions.
« on: October 12, 2015, 12:59:02 AM »
Hey!

I ended up using Heyzap with writing code for what I wanted in my game. There is a Trello task opened for the Heyzap actions so if you would like to see Heyzap actions in Playmaker I would suggest vote the task up https://trello.com/b/1VSKPLcT/addons .

As far as I can tell its the best option right now for the ads and integration is super easy.

Best,
Haralds

10
iOS Help / Re: Slide Ground Stomp
« on: October 12, 2015, 12:51:12 AM »
Hey!

Have you tried to change collision detection on rigidbody from discrete to dynamic on continuous dynamic?

That helped for me once. Let me know how it goes.

Best,
Haralds

11
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: October 12, 2015, 12:45:10 AM »
Hey!

No problem, the suggestion to add an empty FSM to the prefab helped with the errors and everything seems to be working for now.

But anyway it would be nice to know why is that happening. :)

Best,
Haralds

12
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: September 29, 2015, 03:42:58 AM »
Hi,

Thank you. Will be waiting.

Best,
Haralds

13
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: September 27, 2015, 02:23:50 AM »
Hi,

Thank you that got rid of the errors. Still I hope this will be updated soon.

Best,
Haralds

14
iOS Help / Re: PlayMaker Unity 2d prefab on Unity 5.2.x not working...
« on: September 27, 2015, 01:31:09 AM »
Hi!

Yes I tried that same things, not helping me either. I am a bit lost too, also its getting a bit urgent now to get this working. :/

I hope playMaker developers gets on top of this problem soon.

Best,
Haralds

15
iOS Help / PlayMaker Unity 2d prefab on Unity 5.2.x not working... [CLOSED]
« on: September 26, 2015, 03:44:32 PM »
Hello!

It seems that on Unity 5.2.x PlayMaker Unity 2d prefab loses the FSM component and there for problems arise.

Please help!

Best,
Haralds

Pages: [1] 2 3 ... 5