playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - mgants

Pages: [1]
1
Hi,

I am seeing the following errors in my editor logs when I try to build my project for Windows Phone 8, using Unity 5.1, and PlayMaker 1.8.0 Beta. I also saw similiar output with PlayMaker 1.7.8, was hoping the beta would fix it.

Double checking the import options for all of the PlayMaker *.dlls shows that all of the platforms and references seem to be configured correctly. Windows Metro/Universal builds fine.

Maybe related to this line?
Version=1.6.0.0

Would think it should be 1.8.0...will see what's going on there.

In the meantime, any tips?

-----CompilerOutput:-stdout--exitcode: 1--compilationhadfailure: True--outfile: Temp/Assembly-CSharp-firstpass.dll
The class UnityEngine.NetworkPlayer could not be loaded, used in UnityEngine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.FsmEventData could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.Fsm could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.FsmLog could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.Fsm could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.FsmState could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.Fsm could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class BitConverter could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.FsmStateAction could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class HutongGames.PlayMaker.Fsm could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class PlayMakerFSM could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class PlayMakerFSM could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
The class PlayMakerFSM could not be loaded, used in PlayMaker, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null
-----CompilerOutput:-stderr----------


2
Hi,

I am trying to upgrade my project to use Playmaker 1.7.8 for use with Unity 5.
After upgrading, I noticed that every Playmaker FSM component reference on all of my prefabs is broken / missing - about 322 occurrences.

Running the "PlayMaker/Tools/Load All PlayMaker Prefabs in Project" command also confirms "No PlayMaker Prefabs Found!"

I have read through the troubleshooting guide, etc. but have not found any suggestions that seem to help.

I can put a new FSM component on my prefabs, but these are new, empty FSMs, which is not ideal.

Any ideas or suggestions?

Thanks!

mg

Pages: [1]