playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Doh

Pages: [1]
1
Playmaker Help / Apply force on all objects. [SOLVED]
« on: November 29, 2018, 07:32:27 AM »
Hey, I've been setting up some conveyor belt systems over the last couple of days.

I've managed to do it through having the conveyor object send an event to the objects that land on it. Though this method means having every object that has the potential to land on a conveyor have its own FSM just to handle the forces applied to it.

Is there a more simple way to do this?

Ideally I'd like the conveyor to handle everything and just recognize all objects (of a certain layer) within its trigger volume and apply the force to each object itself. This is simple enough with just one object, but I can't see how I'd do it to varying quantities of objects. If there is a way to apply force or set velocity on every object in an array in one state I'd be sorted.

2
Playmaker Bug Reporting / seemingly non-functioning actions [SOLVED]
« on: November 15, 2018, 04:48:14 AM »
I've got a weird problem at the moment. I was trying and trying to get the "get signed angle to target" action to work, though it wouldn't return a value at all, it would just stay at zero no matter how I positioned/rotated the objects involved. Then I added another action to the state in an attempt to find something that would respond. On the simple presence of the extra action, they all came to life. I really don't understand this at all. Could someone more knowledgeable shed some light on this please? Or have I found a bug?

I've included a spliced together screen shot to show what happened. The extra action isn't even set up, just present. The left column is how I'd set it up initially with just the required actions, the middle column is with the extra action and the right column is like the middle column but with the extra action disabled.

3
Playmaker Help / "Get Scene Is Loaded" errors
« on: August 09, 2018, 11:21:28 AM »
Hello, I'm trying to find out if certain scenes are loaded before I attempt to additively load other certain scenes in. I've got all of the scenes added to the build settings list, though every scene the action tries to poll it throws up a log error claiming each scene index to be out of range.

I suspect it's trying to find them in the hierarchy even though I have the scene reference set to "scene at index"(is this not the actual build index?), could someone shed some light on this please? My hair is falling out rapidly!

4
Action Requests / Get Material Float[SOLVED]
« on: February 27, 2018, 10:32:04 AM »
Would be lovely!

There is already a "Set" version, sadly my attempts to convert that failed.

5
Playmaker Bug Reporting / Possible "get closest" bug
« on: February 14, 2018, 06:47:43 AM »
I've found that in my scenario using "array get closest game object" finds the wrong (the furthest) result between the 2 objects I have on the array, though if I replace it with an array maker array list and swap the action for "array list get closest game object" in the the same scenario it finds the correct (the closest) game object.

Using Unity 2017.3.0f3 and the latest stable release of Playmaker.

More details can be provided if this cannot be replicated.

6
Share New Actions / Sphere Cast 2 Ignore Triggers
« on: December 18, 2017, 10:45:29 AM »
Just added "Ignore Triggers" to the existing "SphereCast2" action.

Edit: Noticed the repeat interval had no effect, should be fixed now.

7
Playmaker Help / String Join action[SOLVED]
« on: November 24, 2017, 01:01:47 PM »
Having an issue where the "String Join" action doesn't add the last string in an array. If the array is 5 strings long then it joins the first 4, if it's 3 strings long then it joins the first 2 etc.

Anyone else getting this problem?

8
Playmaker Help / Animator State Sync issue.
« on: November 19, 2017, 07:32:09 AM »
Hey, I'm having an issue I can't seem to fix using the Animator State Synchronization script.

The setup is pretty straight forward, I have an animator with 4 states that form a simple 4 stage loop. I have an FSM on another object that has 5 states, each named appropriately. The 5th state is a transition between two of the animations.

The whole thing functions correctly in sync for the 1st cycle, then on the second time around the transition state is not synchronized.

Has anybody come across a similar issue recently? Any help on this issue would be greatly appreciated!

9
Playmaker Help / error on arraymaker easysave 2 actions
« on: May 21, 2017, 12:50:01 PM »
Hey, so I'm getting an error where the action "Array List Easy Load" states it cannot find the save file, even though it's managed to retrieve the data from the file it states it cannot find.

I've attached 2 images, one just before the load is called and one as it reports the error.

Is it possible that the actions need to be updated?

Cheers

10
Playmaker Help / Array List Get Closest Game Object In Sight
« on: May 12, 2017, 06:05:26 AM »
Hello,

I'm having an issue with the action "Array List Get Closest Game Object In Sight", the problem being it doesn't return any objects for me.

I have however been successfully using "Array List Get Closest Game Object" with no issues.

I've got each version set up exactly the same, feeding from the same Array List in separate tests.

Is anyone else having issues with this one? I'm pretty sure I'm using it correctly and wondering if it's broken or not. It wouldn't surprise me if it's just me being a plum though.

11
Playmaker Help / Changing a gradient value.
« on: April 25, 2017, 05:44:51 AM »
Hey, I'm having some issues trying to use get/set property on a script to change a gradient colour value, as can be seen in the images provided they're public, however they don't show up in the property list.

Any help would be hugely appreciated!

12
Playmaker Help / Finding a child during runtime
« on: April 20, 2017, 08:47:08 AM »
Hey, I'm finding it difficult to find a solution to this.

I have a game object that takes on different child objects during runtime, though only ever one at a time. My issue is getting an FSM to check for the child object once it takes on the new parent.

So far I've only been able to get it to check for a child on start, this results in a negative response obviously as the child is not there yet.

Any pointers would be greatly appreciated!

Pages: [1]