playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - hx

Pages: [1]
1
Hi guys,

there is something bothers me, and seems it happens randomly somehow.
here is the issue:
i am working with hololens, and when i add the action like : destroy the gameobject, or activate(uncheck) the gameobject, it works normally. but when the scene gets a bit complicated, or just because i changed something( even no addiotional content), then this action doesnt work, and it will happen not to all the gameobeject the script were attached, just one or two.
and now the weird thing is: the script did destroy the gameobject, since the gameobject doesnt exist anymore there, but in the playmode scene, it is still there.

so i wonder, how it could be solved? and what is exaclty the problem? would it be that the hololens has lesser cpu, gpu power? but in unity playmode is also like this.

2
Playmaker Help / Unassigned Reference Exception
« on: November 06, 2017, 08:05:24 AM »
Hi guys,

i get this error in my console and i cant figure out why, it was OK several days before, since today it doesnt work somehow:

UnassignedReferenceException: The variable UiTarget of PlayMakerUGuiComponentProxy has not been assigned.
You probably need to assign the UiTarget variable of the PlayMakerUGuiComponentProxy script in the inspector.
UnityEngine.GameObject.GetComponent[Button] () (at C:/buildslave/unity/build/artifacts/generated/common/runtime/GameObjectBindings.gen.cs:38)
PlayMakerUGuiComponentProxy.SetupUiListeners () (at Assets/PlayMaker uGui/Proxies/PlayMakerUGuiComponentProxy.cs:264)
PlayMakerUGuiComponentProxy.Start () (at Assets/PlayMaker uGui/Proxies/PlayMakerUGuiComponentProxy.cs:88)


info: i am using unity 5.61f1, playmaker 1.8.5
screenshot attached.
any answer would be helpful.

3
General Discussion / activate/enable function doesnt work after deploy?
« on: August 23, 2017, 01:14:10 AM »
Hey Guys,
i have been suffering with this issue for a while. I am doing a HoloLens Project using playmaker. Though i think doesnt actually matter which hardware it would be.
The problem is that, when i make the script in playmaker, activate a Gameobject, it doesnt really activate the Gameobject, eventhough when i hit play the script turns to green(which means it works). it happens randomly, and when i get it work in unity, when i hit play button, it works, but when i build the app, and deploy it in the device, then it doesnt work again.
actually i  am even not sure, if it is a playmaker problem? or am i missing something? do i need to do something before a build the app?

4
Playmaker Help / clamp value jumps from min to max value
« on: June 17, 2017, 02:15:32 PM »
Hello everyone,
i have been struggeling on this topic for over two weeks. i want to rotate a gameobject with mouse in a limited range. x axis from 0 to 60. y axis from 0 to 360, z axis from 0 to 60.
this is what i did.
1. get mouse delta position x,y.
2. multiply the float x,y with -10000 and 10000
3. rotate the gameobject in axis x with float y, axis y with float x
4. get the current rotation from gameobject, eulerangle x, eulerangle y, eulerangle z as variante.
5. clamp the eulerangle x ,z between 0 to 60
6. set rotation with eulerangle x , eulerangle z


however, this works in a strange way, in case of max value, when the limit is reached, the gameobject doesnt go over, but in case of min value, it is always return to max value again. so my gameobject get not smoothly rotating, it shakes always like crazy.

I have tried some Direction as follows.
1. get signed angle to target.
2. set another event to compare the float min, but it stucks in the compare state.


can someone help me out of this??


Pages: [1]