playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - miguelfanclub

Pages: [1] 2 3
1
Playmaker Help / Re: Playmaker wont load after installing Array Maker
« on: January 16, 2018, 06:36:11 AM »
Thanks dude. Its working now.

2
Playmaker Help / Re: Unity doesn't save changes made with Array Maker
« on: January 15, 2018, 10:06:41 AM »
I just posted a new topic about this.

Installing array maker from the ecosytem makes playmaker to not to being loaded.

http://hutonggames.com/playmakerforum/index.php?topic=16451.0

3
Playmaker Help / Playmaker wont load after installing Array Maker[SOLVED]
« on: January 15, 2018, 07:53:41 AM »
After installing it from the ecosystem:

Assets/PlayMaker ArrayMaker/__internal__/Editor/PlayMakerArrayListProxyInspector.cs(47,4): error CS0103: The name `EditorSceneManager' does not exist in the current context

Latest version of unity and latest version of playmaker

4
Playmaker Help / How to know who is calling a global event
« on: December 18, 2017, 06:19:50 AM »
Hi!

Is there a way to know whicf fsm is calling a global event? Im trying to debug something and its getting difficult.

Thanks

5
Playmaker Help / Re: Unity UI crossfade Alpha action
« on: September 30, 2017, 05:37:59 AM »
Im also trying to use this action. Doesnt seems to work at all.

6
So my camera has mouse look. Im calling a global event to stop it when i want, like when showing an UI pop up window.

Probem is that when i come back via global event to continue doing mouse look action, it randomly rotates the camera exactly 60ยบ, which is the value of the maximum X field.

You can see mouse look working. When I trigger the UI, I stop it. When I click on the continue button, i call it again, but most of the times, i get the annoying rotation.

In the video you can see it fails, but then after sec 10, it works a couple of times   (cam doesnt rotate when i call again mouse look)

https://youtu.be/933g6MddVUw

7
Playmaker Help / Re: GET FSM Variable
« on: September 22, 2017, 11:57:06 AM »
OK, because im getting weird errors stuff in the editor log (no errors while running)
as well as weird behaing that SHOULD work, so I wanted to discard this.

Thanks

8
Playmaker Help / GET FSM Variable [SOLVED]
« on: September 22, 2017, 05:20:44 AM »
Just to be sure:

Im not using global variables at all, so in order to use a variable value in another FSM I always get its value and store it in another local variable.

Question is: Can this local variable where im storing the variable that i get from another FSM have the very same name?

Like im getting a variable called "Answered" from FSM A and im storing it on a variable called "Answered" in the FSM B. Both of them locals of their own  respective FSMs

Thanks

9
@Jan

From sec 5 you can see. The icon doenst start where it supposed to do. You can see for a few frames out of its original position and after that, it goes where it should.

Here is a screenshot of my FSM:

https://puu.sh/xDwVI/d1565a7ce0.png

10
@jean

Im doing exactly the  uGuiTextFollowGameObject code. The only difference is that im calling those actions ONLY when I start firing my hitted object actions via global event. If they are runing on START i dont have the glitch.

Problem is that I shouldnt have hundreds of objects with hidden icons executing their world position all the time every frame.

11
Im getting this annoying glitch trying to overlay world screen icons on top of my prefabs.
Is there a way to overcome this?

https://youtu.be/_xau3N3c0Z8

Or a better way to achieve it

Thanks

12
Playmaker Help / Re: Lag on Playmaker Editor Window: becoming really slow
« on: September 12, 2017, 03:34:12 PM »
Ok. SO I think I know whats going on and probably is related.

I have my unity peoject synched on 3 computers. Home, Laptop and home.
Im using gdrive.... and sometimes it gives me error that cant update some files, and those files are normally meta files and sometimes scene.meta

The scene where i have severe lag, is an scene where I just discovered there were some console errors of gameobjects that dont exist They are not in the hierarchy. I guess my scene is corrupted due synch errors and thats why also that scene is also not building properly once I run the exe.

Is that possible?


13
Playmaker Help / Re: Camera Rotation Problem [VIDEO] [SOLVED]
« on: September 11, 2017, 11:44:01 AM »
Thanks djay. I was trying to investigate more and I discovered I was calling mouse look twice on an FSM and that was creating the issue. Now it works.

It drove me crazy yesterday after been working on the same stuff for like 15h.

Thanks

14
Playmaker Help / Loosing actions dependencies with prefab[SOLVED]
« on: September 11, 2017, 11:41:15 AM »
So I have a charctaer controlloer that holds all the information I need as a prefab.
I also have other prefabs that ask infotmation from character controller (variables) and also send events to him.

So when I create a new scene and place the character controller all is good. But when I add the other prefabs, then they loose some conections (reference objects that holds variables mostly) and then I have to reconect everything again.

Is this the expected behaviour? I never use global variables so I always use the get varibale in order to operate with them. Those are the fields where I loose the conections.

Thanks

15
Playmaker Help / Re: Lag on Playmaker Editor Window: becoming really slow
« on: September 11, 2017, 06:51:03 AM »
@Jean Will do.

I got another issue (maybe this can also help). When dragging correct game object in order to get a variable in an action it doesnt work. It stays for a few seconds and then show me the menu of "new variable etc". If I select another object and come back to the same one, then it works sometimes. Its very random.

In that screenshot I was just dragging the correct gameobject
https://puu.sh/xx6Xg/7d81490cae.png

Pages: [1] 2 3