playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - miguelfanclub

Pages: 1 2 [3] 4 5
31
Playmaker Help / GET FSM Variable [SOLVED]
« on: September 22, 2017, 05:20:44 AM »
Just to be sure:

Im not using global variables at all, so in order to use a variable value in another FSM I always get its value and store it in another local variable.

Question is: Can this local variable where im storing the variable that i get from another FSM have the very same name?

Like im getting a variable called "Answered" from FSM A and im storing it on a variable called "Answered" in the FSM B. Both of them locals of their own  respective FSMs

Thanks

32
@Jan

From sec 5 you can see. The icon doenst start where it supposed to do. You can see for a few frames out of its original position and after that, it goes where it should.

Here is a screenshot of my FSM:

https://puu.sh/xDwVI/d1565a7ce0.png

33
@jean

Im doing exactly the  uGuiTextFollowGameObject code. The only difference is that im calling those actions ONLY when I start firing my hitted object actions via global event. If they are runing on START i dont have the glitch.

Problem is that I shouldnt have hundreds of objects with hidden icons executing their world position all the time every frame.

34
Im getting this annoying glitch trying to overlay world screen icons on top of my prefabs.
Is there a way to overcome this?

https://youtu.be/_xau3N3c0Z8

Or a better way to achieve it

Thanks

35
Playmaker Help / Re: Lag on Playmaker Editor Window: becoming really slow
« on: September 12, 2017, 03:34:12 PM »
Ok. SO I think I know whats going on and probably is related.

I have my unity peoject synched on 3 computers. Home, Laptop and home.
Im using gdrive.... and sometimes it gives me error that cant update some files, and those files are normally meta files and sometimes scene.meta

The scene where i have severe lag, is an scene where I just discovered there were some console errors of gameobjects that dont exist They are not in the hierarchy. I guess my scene is corrupted due synch errors and thats why also that scene is also not building properly once I run the exe.

Is that possible?


36
Playmaker Help / Re: Camera Rotation Problem [VIDEO] [SOLVED]
« on: September 11, 2017, 11:44:01 AM »
Thanks djay. I was trying to investigate more and I discovered I was calling mouse look twice on an FSM and that was creating the issue. Now it works.

It drove me crazy yesterday after been working on the same stuff for like 15h.

Thanks

37
Playmaker Help / Loosing actions dependencies with prefab[SOLVED]
« on: September 11, 2017, 11:41:15 AM »
So I have a charctaer controlloer that holds all the information I need as a prefab.
I also have other prefabs that ask infotmation from character controller (variables) and also send events to him.

So when I create a new scene and place the character controller all is good. But when I add the other prefabs, then they loose some conections (reference objects that holds variables mostly) and then I have to reconect everything again.

Is this the expected behaviour? I never use global variables so I always use the get varibale in order to operate with them. Those are the fields where I loose the conections.

Thanks

38
Playmaker Help / Re: Lag on Playmaker Editor Window: becoming really slow
« on: September 11, 2017, 06:51:03 AM »
@Jean Will do.

I got another issue (maybe this can also help). When dragging correct game object in order to get a variable in an action it doesnt work. It stays for a few seconds and then show me the menu of "new variable etc". If I select another object and come back to the same one, then it works sometimes. Its very random.

In that screenshot I was just dragging the correct gameobject
https://puu.sh/xx6Xg/7d81490cae.png

39
Playmaker Help / Re: Talking with the game
« on: September 11, 2017, 05:36:47 AM »
Sorry dude, you are right!
Let me know if you find something similar to what you are looking for.

40
Playmaker Help / Camera Rotation Problem [VIDEO] [SOLVED]
« on: September 10, 2017, 03:25:55 PM »
Hi again.

Im improoving my character movement.
Character is moving 4m in fixed movement and rotating 90ยบ everytime you rotate.
It works perfectly using the keys.

Now Im trying to rotate the character also by moving the camera towards the edges of the screen (i have a tolerance to not to be too intrusive) so the character and the camera will auto rotate and player will be looking again to the center (0.0.0 self)

It works pretty well, but I have annoying behaviour that I cant fix.

I think its related to the mouselook script that the camera has attached.
I can reproduce the bug if I move the mouse while the "auto movement" is taking place. During the movement, "mouselook" is deactivated and I also control that no keys can be pressed, when movement is ended, "moselook" is again activated.

I could be sure if i can totally "disconect" the mouse imput while the movement is happening. Dont know.

In sec 10 you can clearly see what happens, also on 30.

Video Link:
https://youtu.be/ySxyfy1pkcg

Also, the scene doesn work when I build it (i cant rotate at all) so something must be wrong...
Any Idea?
Thanks!

41
Work In Progress... / Re: Templar
« on: September 10, 2017, 02:15:30 PM »
Ive done a pretty solid character controller.
Im able to raycast efficiently (all is done by event) and now I can detect interactable elements and show correct UI depending on the distance. Character cant move if there is collission around (this scene has no wall)

Video link
https://youtu.be/SHLCao20JwA


42
Work In Progress... / Templar
« on: September 10, 2017, 02:12:26 PM »
Just showcasing whats going on with my project, used to keep learning and motivating myself.

Its a game I designed time ago. An FP Dungeon Crawler with turn based combat.
Enemies are going to be fully PBR 2D Images showing front/side/back sprites.
Im doing everything, coding and art  8)

(Old mockup)


Turn Based Combat mockup



UI mockup




43
Playmaker Help / Re: Lag on Playmaker Editor Window: becoming really slow
« on: September 10, 2017, 12:20:42 PM »
Did all that. No help.

Now, im doing an exe, no errors so far. When I run it, scene start and its not doing at all what it supose to do. Checked it on Unity scene, replicated it playing the exe --> Fails

I really feel something is going wrong

Any idea

44
Hey dude,

now it seems to work. Tried several times to do it and didnt work. Im thinking that maybe was the speed (it was set to 0)

Thanks

45
I have no steps to reproduce. Just been working the whole day on my project.... the editor has been becoming slower and slower. Now, whatever I do on the State Tab im getting like 2-3 secs lag: Unfolding actions, writing names on any label etc (each letter I type I have lag)

Also, Im getting weird acting. Things that worked stoped to work , things that they should really work now they dont.

Restarting doesnt help

I have also noted that some users experienced this in the past and was related to unfolded actions. Is not my case, using control to fold them all doesnt fix the lag.

My Unity version: 2017.1.0f3
Playmaker version: 185f8

Is anyone experiencing this?

Pages: 1 2 [3] 4 5