playMaker

Author Topic: Unity to xCode errors  (Read 1459 times)

PlaymakerNovice

  • Playmaker Newbie
  • *
  • Posts: 18
    • View Profile
Unity to xCode errors
« on: December 14, 2015, 10:18:11 AM »
I've been trying to get my iOS Unity game to work on xCode but I keep getting problems. The main error I get inside of xCode is 'Unused variable L_6', and I get hundreds of those errors. When I build the game to xCode within Unity I get these errors:

Unity xcode plugin has not current Xcode in its compatibility list. Please launch the project manually UnityEditor.HostView:OnGUI()

Splash screen images not provided: Mobile Splash Screen*, iPhone 3.5''/Retina, iPhone 4''/Retina, iPhone 4.7''/Retina, iPhone 5.5''/Retina, iPhone 5.5'' Landscape/Retina, iPad Portrait, iPad Landscape, iPad Portrait/Retina, iPad Landscape/Retina UnityEditor.HostView:OnGUI()

Unknown file extension: .xml UnityEditor.HostView:OnGUI()

Unknown file extension: .browser UnityEditor.HostView:OnGUI()

Unknown file extension: .map UnityEditor.HostView:OnGUI()

Unknown file extension: .config UnityEditor.HostView:OnGUI()

Unknown file extension: .aspx UnityEditor.HostView:OnGUI()

Unknown file extension: UnityEditor.HostView:OnGUI()

Unknown file extension: .ini UnityEditor.HostView:OnGUI()

Unknown file extension: .dat UnityEditor.HostView:OnGUI()

Don't forget to change iPhoneBundleIdentifier in the Player Settings before submitting to the App Store. UnityEditor.HostView:OnGUI()

Game scripts or other custom code contains OnMouse_ event handlers. Presence of such handlers might impact performance on handheld devices. UnityEditor.HostView:OnGUI()

I've tried using no assets, all assets, and only one asset, but none of these worked. I've also tried changing to iPhone only instead of Universal, and Mono2x as the scripting backend. I still get these same errors. Also I have the latest versions of Unity and xCode. I would really appreciate it if I could get some help because I want to release my games to the App Store as soon as possible. If you need any more information regarding the problem and solutions I've tried please ask so I can find the answer quickly. Thank you!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Unity to xCode errors
« Reply #1 on: January 25, 2016, 11:07:04 PM »
Hi,

 can you try a fresh project, with just PlayMaker and a simple scene that rotate a cube?

 if you still get this error then we have a problem.

if this error only happens in your main project, then did you install other packages from the asset store?

-- What custom actions are you using?
-- Are you using actions like "set property" "Get property" or "method invoke"?

-- always use IL2cpp, you won't be able to make it to the app store otherwise.

Bye,

 Jean

memetic arts

  • Full Member
  • ***
  • Posts: 140
    • View Profile
Re: Unity to xCode errors
« Reply #2 on: March 31, 2016, 12:19:33 AM »
I was getting the exact same set of errors the other day, and it was the "scripting backend" build setting that was causing it (and beyond that, I'm pretty sure it was the stripping level setting, which goes away when you select IL2CPP). 

So as Jean said, use IL2CPP and the errors should go away.