playMaker

Author Topic: Can't Change Action Parameters [SOLVED]  (Read 1114 times)

Losemetry

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Can't Change Action Parameters [SOLVED]
« on: February 08, 2016, 10:38:23 PM »
I've been encountering a problem where in any state machine I create, the action parameters will not change from what I first set them to be.


Let's say if I did an add force on an object 100 in the Z-space: every time I put in a new value and hit play, it will reset to 100 when I go into play mode. I can even remove the action and re-add it and it will still be 100 when I go into play mode.
« Last Edit: February 09, 2016, 11:12:36 AM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3201
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Can't Change Action Parameters
« Reply #1 on: February 08, 2016, 11:14:57 PM »
Are you using the latest version? 1.8.0.f42

Losemetry

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Can't Change Action Parameters
« Reply #2 on: February 09, 2016, 09:20:28 AM »
I just updated to the version that was released yesterday. Unfortunately, nothing has changed.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3201
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Can't Change Action Parameters
« Reply #3 on: February 09, 2016, 10:56:32 AM »
Did you import 1.8 from the Welcome Screen? Can you confirm the Paymaker version in the PlayMaker > About.

Losemetry

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Can't Change Action Parameters
« Reply #4 on: February 09, 2016, 11:11:49 AM »
I had actually updated to 1.7.8.4. I didn't know whether or not it was a good idea to use beta versions, but it did solve the problem. Thank you.