playMaker

Author Topic: Always with the "Please import Playmaker for Unity 5."! [SOLVED]  (Read 2192 times)

TellMeTellMeDontTellMe

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
I'm running Unity5 and am using Playmaker 1.8.0f43.

Using a Mac, OS X El Capitan 10.11.1

No matter what I do I get the error message:

     PlayMaker AutoUpdater

     Please import Playmaker for Unity 5.

     To get the latest version, update in the Unity Asset Store or download from Hutong Games Store.

It interrupts everything and I have to tap OK to dismiss it.

I've tried updating, re-importing, start new projects, no matter what, I get this message at least every minute. It is incredibly annoying.

What do I do to make it stooooooooooooppppppp?!?!?!  :'( :'( :'(
« Last Edit: September 09, 2016, 12:29:52 PM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3477
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Always with the "Please import Playmaker for Unity 5."!
« Reply #1 on: April 29, 2016, 04:17:20 PM »
Hmmm, I'll investigate...

In the meantime you can delete:
PlayMaker\Editor\PlayMakerAutoUpdater.cs

Mutajon

  • Playmaker Newbie
  • *
  • Posts: 20
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."!
« Reply #2 on: September 08, 2016, 02:25:07 AM »
Any news regarding this issue?
I'm also suffering from it...
Using unity 5.3 and playmaker 1.8.2

Deleting PlayMakerAutoUpdater.cs gives me another error (auto updater missing) which prevents me from going to play mode.

Thanks

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3477
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Always with the "Please import Playmaker for Unity 5."!
« Reply #3 on: September 08, 2016, 11:08:10 AM »
Is PlayMaker.dll in Assets\Plugins\PlayMaker\?
If it's somewhere else (e.g., Assets\PlayMaker\PlayMaker.dll) move it to Assets\Plugins\PlayMaker\ in the Unity Project View. Do not use File Explorer/Finder to move the file and BACKUP your project first!

Let me know if this fixes the issue for you.

Mutajon

  • Playmaker Newbie
  • *
  • Posts: 20
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."!
« Reply #4 on: September 09, 2016, 08:22:03 AM »
Indeed it seems to have solved it :)
Thanks!

TellMeTellMeDontTellMe

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."!
« Reply #5 on: September 09, 2016, 10:27:12 AM »
Yes solved for me too. Awesome, thanks.

imtrobin

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #6 on: December 18, 2017, 04:35:41 AM »
I'm using Playmaker 1.8.5, and I moved Playmaker into plugins folder. It keeps getting this dialog too on Play, and no way to turn it off.

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3908
    • View Profile
    • jinxtergames
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #7 on: December 18, 2017, 03:25:13 PM »
Hi,
You should not move the playmaker folder.
Did you have the issue before you moved it?

imtrobin

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #8 on: December 18, 2017, 06:34:06 PM »
No, was working fine before. But there are many packages imported, and it's better to organize them in a third party folder.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13887
  • Official Playmaker Support
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #9 on: December 19, 2017, 11:59:18 PM »
Hi,

 you should never move files coming from packages, it's unfortunate but Unity file management is very edgy and you can run into so many issues with this that it's best not to touch it and instead create your owne folder inside the assets where you put all the stuff you bring yourself for that particular project, then you are on the safe side.

 Bye,

 Jean

imtrobin

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #10 on: December 20, 2017, 03:39:00 AM »
I know that's what many people say, but not really a good way when there are more than 50 packages involved.

Most packages have option to specify the folder if they are moved, so hope you can add that too. For now I will delete the auto update.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13887
  • Official Playmaker Support
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #11 on: December 22, 2017, 12:05:02 AM »
Hi,

 the problem is that even if assets allow you to move files around, there is no guarantee that future iterations of Unity will not break this one way or the other. We had the case few times over the various cycles of Unity, the last one being If I recall properly in 5.4, and backups won't help you in this case.

but yes, normally this should be ok in most cases.


bye,

 Jean

imtrobin

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Always with the "Please import Playmaker for Unity 5."! [SOLVED]
« Reply #12 on: December 22, 2017, 01:28:38 AM »
I have been using Unity since v3, and organizing packages like these. No such problems, except a few improvements like Plugins folder.