playMaker

Author Topic: System.Type madness  (Read 721 times)

christougher

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
System.Type madness
« on: September 06, 2016, 05:26:51 AM »
Hi, it looks like some more WSA fixes are on the way according to the release notes.  Will this error be getting addressed?

Assets\PlayMaker Utils\Wizards\LinkerWizard\LinkerData.cs(88,38): error CS1061: 'System.Type' does not contain a definition for 'Assembly' and no extension method 'Assembly' accepting a first argument of type 'System.Type' could be found (are you missing a using directive or an assembly reference?)

I updated multiple things, including Unity, Visual Studio and several SDKs and now I get a bunch of errors regarding system.type, but this is the only Playmaker error.  Any tips on how to fix it prior to the release of 1.8.3?

christougher

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Re: System.Type madness
« Reply #1 on: September 06, 2016, 12:29:53 PM »
Also I tried using the WP8 Playmaker.dll instead of the metro one just to see what happened and it threw an additional error...

'System.Type' does not contain a definition for 'IsSubclassOf' and no extension method 'IsSubclassOf' accepting a first argument of type 'System.Type' could be found (are you missing a blah blah blah....

So this isn't a problem with the Metro dll and the only reason I bring it up is I have an unrelated script throwing the same error.  Can you share the fix for this? Thx.