playMaker

Author Topic: Ecosystem 0.5.2 not working in 2017.1.1f1 [SOLVED]  (Read 528 times)

adrian

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Ecosystem 0.5.2 not working in 2017.1.1f1 [SOLVED]
« on: October 01, 2017, 11:21:26 AM »
Hi,

As the title says, Ecosystem 0.5.2 not working in 2017.1.1f1

With the following error, can anyone help pls.

NullReferenceException: Object reference not set to an instance of an object
System.IO.File.WriteAllBytes (System.String path, System.Byte[] bytes) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:595)
Net.FabreJean.PlayMaker.Ecosystem.EcosystemBrowser+<ProceedWithImport>c__Iterator0.MoveNext () (at Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs:2895)
Net.FabreJean.UnityEditor.EditorCoroutine.update () (at Assets/net.fabrejean/Editor/Plugins/EditorCoroutine.cs:53)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:109)
« Last Edit: October 09, 2017, 11:27:26 AM by Alex Chouls »

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3062
    • View Profile
    • jinxtergames
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #1 on: October 01, 2017, 06:34:20 PM »
Hi,
You can get the latest (i think 0.5.3 at the moment) version here :
https://hutonggames.fogbugz.com/default.asp?W1181

adrian

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #2 on: October 02, 2017, 12:20:18 PM »
Thank you, yes that's the version I downloaded today, no joy. Am I the only one, totally killing all use of playmaker for me :(
Is there any straggling files that need deleting or something? Have tried a few projects and no luck.

akmccullough

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #3 on: October 02, 2017, 12:37:05 PM »
My entire class is struggling with this same error. No luck!

adrian

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #4 on: October 02, 2017, 02:04:46 PM »
Cheers akmccullough, it's really a showstopper for using playmaker, finger crossed for a fix soon  :-[

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3062
    • View Profile
    • jinxtergames
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #5 on: October 04, 2017, 09:41:40 AM »
Hi,
i have send a message to jean on skype but he has not been online yet,
(I think he is @ the unity unite event.

You can find and get most of the custom actions and packages on jean's github :

https://github.com/jeanfabre

adrian

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #6 on: October 05, 2017, 01:01:29 PM »
Thank you djaydino, the one action I am trying to find is the set line renderer position but I can only find a png file on github? Thank you for looking into this :)


djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3062
    • View Profile
    • jinxtergames
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #8 on: October 05, 2017, 07:34:51 PM »
Hi,
I tested on unity  2017.1.1f1 and Pm 1.8.5 and Ecosystem 0.5.3.

It seems to work on my end.

adrian

  • Playmaker Newbie
  • *
  • Posts: 27
    • View Profile
Re: Ecosystem 0.5.2 not working in 2017.1.1f1
« Reply #9 on: October 09, 2017, 05:23:34 AM »
Suddenly came to life, thank you for the help in the meantime, please do mark as solved  :)