playMaker

Author Topic: Blendshapes and Playmaker Problem[SOLVED]  (Read 500 times)

serenefox

  • Junior Playmaker
  • **
  • Posts: 93
    • View Profile
    • Serenefox Games
Blendshapes and Playmaker Problem[SOLVED]
« on: February 17, 2018, 12:36:27 AM »
Hi,

I am using the blendshape actions on the ecosystem and I have a Fsm where it randomly picks a state with a "animate float" action and a "set blendshape weight" action. The float variable will increase and the blend shape field will change. The problem is I have three sets of states, one for happy, one for scared, and one for excited,and only the happy one works as expected. The other two start off well but as soon as it exits the state after the animate float finishes their weights reset.

Also on a side note the two blendshapes that don't work properly, don't work at all unless my animator component is on "animate physics".

Anybody know whats going on?

Unity 2017.2
Playmaker 1.8.9
« Last Edit: March 05, 2018, 11:35:00 PM by jeanfabre »
Most Recent Published Games:
Don't Pop! Dungeon - iOS/Android

nFighter

  • Beta Group
  • Junior Playmaker
  • *
  • Posts: 96
    • View Profile
    • multiplayer adult fighting
Re: Blendshapes and Playmaker Problem
« Reply #1 on: February 19, 2018, 03:36:21 AM »
If the blendshapes don't work properly I would suggest to search for a problem on a model side. The bug could happen far beyond playmaker.
indie developer of multiplayer adult fighting
http://nakedfighter3d.com

serenefox

  • Junior Playmaker
  • **
  • Posts: 93
    • View Profile
    • Serenefox Games
Re: Blendshapes and Playmaker Problem
« Reply #2 on: February 19, 2018, 10:54:34 PM »
They work totally ok in the editor but when I try to access them from playmaker they don’t work. I ended up just making them work as an animation clip. I believe the animator is somehow overriding the blendshapes when trying to use both together.
Most Recent Published Games:
Don't Pop! Dungeon - iOS/Android

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13137
  • Official Playmaker Support
    • View Profile
Re: Blendshapes and Playmaker Problem
« Reply #3 on: February 20, 2018, 10:56:29 PM »
Hi,

 Can you wrap up a minimal repro so that I can play around with your case and find what's going on?

 Are you using SetProperty/GetProperty ? if that's the case, then you might want to use the Linker Wizard ( on the ecosystem) that properly includes in the build the necessary classes.

 Bye,

 Jean

serenefox

  • Junior Playmaker
  • **
  • Posts: 93
    • View Profile
    • Serenefox Games
Re: Blendshapes and Playmaker Problem
« Reply #4 on: March 05, 2018, 02:40:43 AM »
Hi Jean,

I’m not using get or set property at all. I know you are very busy and since I found a workaround I don’t think it is necessary to send a repro. Unless it will benefit the playmaker community I am ok with the work around. Thanks though! :)
Most Recent Published Games:
Don't Pop! Dungeon - iOS/Android

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3241
    • View Profile
    • jinxtergames
Re: Blendshapes and Playmaker Problem
« Reply #5 on: March 05, 2018, 05:23:51 PM »
Hi,
Maybe you can mention the workaround for others?  ;D