playMaker

Author Topic: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker[SOLVED]  (Read 1120 times)

InbalTal

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Hi.
When I Import Playmaker Vuforia to unity 2018.1.6f1 and hit play I get an Error play Massege. :(
When I delete the Playmaker Vuforia file everything is OK  :)

I test the same Package on Unity 2017.3.1f1 and everything is OK  :)

What could be the problem?

Inbal
« Last Edit: November 01, 2018, 03:50:47 AM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #1 on: July 11, 2018, 12:13:54 AM »
Hi,

 Please don't double post and prefer bumping a thread and ping me via pm.

What is the error message? It likely needs an update though, I'll see what I can do to provide something early next week, please bump me next tuesday if I did not provide.

 Bye,

 Jean

InbalTal

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #2 on: July 11, 2018, 04:35:36 AM »
Hi
I open A new unity 2018.1.6f1 File with the Newst Playmaker & Vuforia for Playmaker from the Ecosystem.
accept the playmaker & vuforia thier is no other data in the file
when I hit play Button this error is written on the console:

Assets/PlayMaker Vuforia/Actions/VuforiaGetExtendedTracking.cs(28,3): error CS0246: The type or namespace name `IEditDataSetBehaviour' could not be found. Are you missing an assembly reference?

InbalTal

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #3 on: July 15, 2018, 07:34:04 AM »
Even though I thought the solution I got a week ago was good, once I had to change to unity from ver 2018.1.6f to 2018.1.8 it stopped working and now that I've downgraded back to prev version it's still not working. I got the same error all over again. Need solution ASAP, please advise.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #4 on: July 16, 2018, 12:12:35 AM »
Hi,

 yes, I'll get on this to release an update this week.

 Bye,

 Jean

InbalTal

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #5 on: July 16, 2018, 03:32:15 AM »
thank's
I hope this will be fix asap

Inbal

InbalTal

  • Playmaker Newbie
  • *
  • Posts: 29
    • View Profile
Hi
Until you will update the Voforia Playmaker for Unity
Everything is Working fine for Voforia 7.1.35
I check on Unity 2018.1.6f1 / 2018.1.8f1

1. Download Playmaker form Assets Store (Free)
2. Download Ecosystem from Addons (Playmaker)
3. Download Vuforia for Playmaker from Ecosystem
4. Download Substance form Assets Store (Free)
5. Download PalyMakerUtils from Ecosystem

Good Luck

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #7 on: July 18, 2018, 01:41:10 AM »
Hi,

 ok,

First thing, I updated Vuforia package on the Ecosystem to use the latest PlayMaker Utils, so I strongly recommend you update your package.

second, with that package, it works fine with Vuforia 7.1.35 on Unity 2018.2f5

I have had many issues with the 2018.1 release and I would suggest you move to .2.

can you confirm that on a fresh project in 2018.2 it works? if that's the case, it's a case of cleaning up your project and install the packages fresh. Let me know if that still doesn't work after that.

 Bye,

 Jean

craigz

  • Full Member
  • ***
  • Posts: 148
    • View Profile
    • Haven Made
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #8 on: October 01, 2018, 07:29:41 PM »
Just wanted to chime in on here again :)

Looks like with Vuforia 7.5.20 this is an issue again.

Using Unity 2018.2.10f1 over here. Going to try and downgrade Vuforia :)

-craigz

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #9 on: October 02, 2018, 12:23:54 AM »
Hi,

 ok, try to put PLAYMAKER_VUFORIA_7_2_20_OR_NEWER in the player settings Scripting define symbols field.


else, can you tell me what error you get in the console?

 Bye,

 Jean

craigz

  • Full Member
  • ***
  • Posts: 148
    • View Profile
    • Haven Made
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #10 on: October 02, 2018, 08:17:00 AM »
No dice with the updated scripting define symbols.

Here is the error:
Code: [Select]
Assets/PlayMaker Vuforia/Actions/VuforiaSetPersistExtendedTracking.cs(29,13): error CS1061: Type `Vuforia.ObjectTracker' does not contain a definition for `PersistExtendedTracking' and no extension method `PersistExtendedTracking' of type `Vuforia.ObjectTracker' could be found. Are you missing an assembly reference?
Let me know if there's anything else I can do to help :)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #11 on: October 02, 2018, 11:23:48 PM »
Hi,

 ok, it's likely because you had this from a long time ago, simply delete that file, it's not needed anymore.

 Normally a clean install of vuforia playmaker support should get rid of that action.

 Bye,

 Jean

craigz

  • Full Member
  • ***
  • Posts: 148
    • View Profile
    • Haven Made
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #12 on: October 03, 2018, 05:40:12 AM »
Actually it was a fresh project :) I'm a new user to vuforia, though I have done the initial setup for enabling XR etc via their docs.

I downloaded the 2017 vuforia playmaker version through ecosystem and am using Vuforia 7.5.2.

Just tried clearing Vuforia playmaker support and reimporting, same issue.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13535
  • Official Playmaker Support
    • View Profile
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #13 on: October 03, 2018, 11:36:02 PM »
Hi,

 and if you delete the offending file , is it better?

you should not download the 2017 version of vuforia playmaker is you are on 2018.


 Bye,

 Jean

craigz

  • Full Member
  • ***
  • Posts: 148
    • View Profile
    • Haven Made
Re: unity 2018.1.6f1 + Playmaker 1.9 +vuforia for playmaker
« Reply #14 on: October 04, 2018, 09:57:20 AM »
Hi,

Downloading the other version of Vuforia Playmaker (Unity 5 on ecosystem) gives this error.

Code: [Select]
Assets/PlayMaker Vuforia/Scripts/PlayMakerVuforiaVirtualButtonProxy.cs(60,31): error CS0246: The type or namespace name `VirtualButtonAbstractBehaviour' could not be found. Are you missing an assembly reference?

Deleting the offending file on 2018 gives this error:

Code: [Select]
Assets/PlayMaker Vuforia/Actions/VuforiaGetExtendedTracking.cs(34,3): error CS0246: The type or namespace name `IEditDataSetBehaviour' could not be found. Are you missing an assembly reference?
Honestly, the main reason this is an issue is that Vuforia doesn't host past versions of their plugin (no idea why... it's really obnoxious). I read somewhere they had depreciated some functionality on extended tracking?

Vuforia Engine v7.2.20
"The Extended Tracking API has been deprecated. Use the Device Tracker to continue tracking when targets go out of camera view"

https://library.vuforia.com/content/vuforia-library/en/articles/Release_Notes/Vuforia-SDK-Release-Notes.html