playMaker

Author Topic: Unity 2018.3b2 compatibility  (Read 59 times)

welltold

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Unity 2018.3b2 compatibility
« on: September 21, 2018, 01:11:01 PM »
Hello,

I was wondering if there was beta version of Playmaker that fixes some of the issues I was having with Playmaker in the Unity 2018.3 beta. I am assuming it has to do with the new nested prefab functionality with errors like this:

Code: [Select]
MissingMethodException: UnityEngine.Object UnityEditor.PrefabUtility.GetCorrespondingObjectFromSource(UnityEngine.Object)
It also seems like opening the action browser doesn't work.

Any help would be much appreciated!

Thanks!

krmko

  • Beta Group
  • Hero Member
  • *
  • Posts: 777
    • View Profile
    • Fat Pug Studio
Re: Unity 2018.3b2 compatibility
« Reply #1 on: September 21, 2018, 01:21:28 PM »
I'm not having that problem. Actually, i don't have any errors.

https://docs.unity3d.com/ScriptReference/PrefabUtility.GetCorrespondingObjectFromSource.html

Does it appear when you try editing a prefab fsm from instance?

welltold

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unity 2018.3b2 compatibility
« Reply #2 on: September 21, 2018, 01:26:33 PM »
What Version of Playmaker were you using? I just have 1.9.0 currently.

Thanks!

krmko

  • Beta Group
  • Hero Member
  • *
  • Posts: 777
    • View Profile
    • Fat Pug Studio
Re: Unity 2018.3b2 compatibility
« Reply #3 on: September 21, 2018, 01:44:44 PM »
1.9.1 beta, but it's the iteration before improved prefabs came out, so i don't think anything's been changed.

welltold

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unity 2018.3b2 compatibility
« Reply #4 on: September 21, 2018, 03:10:52 PM »
Yeah, the error was from editing an fsm on a prefab it was attached to. Do you know how to get access to the beta versions to see if that might fix this issue?

Thanks again!

krmko

  • Beta Group
  • Hero Member
  • *
  • Posts: 777
    • View Profile
    • Fat Pug Studio
Re: Unity 2018.3b2 compatibility
« Reply #5 on: Today at 02:52:32 AM »
Contact Jean on Djaydino.