Playmaker Forum

PlayMaker Help & Tips => PlayMaker Help => Topic started by: upOwlNight on January 28, 2016, 12:35:22 AM

Title: [SOLVED]why are my variables changing when I hit play? quick vid in comments
Post by: upOwlNight on January 28, 2016, 12:35:22 AM
yes vertical video, because I felt it served a purpose :) 
anyways... what's happening here? It's a fresh scene with only this FSM
https://vimeo.com/153336208 (https://vimeo.com/153336208)
Title: Re: why are my variables changing when I hit play? quick vid in comments
Post by: mdotstrange on January 28, 2016, 01:40:31 AM
What version of Unity/Pmaker are you running?

I saw this behavior when using Unity 5.3 and Playmaker 1.7- went away when I upgraded to 1.8
Title: Re: why are my variables changing when I hit play? quick vid in comments
Post by: upOwlNight on January 28, 2016, 03:01:28 AM
Thank you so much. This seemed to clear it right up. I was terrified to use 1.8 because it said BETA.

I went to the gym feeling hopeless, and came back to an answer, really. Thanks. 

Any ideas why screen to world 1, 1, 0 (normalized) would return 0, 0, -7.8? I don't see how this is possible, but at least my variables are no longer glutting out on me.
Title: Re: why are my variables changing when I hit play? quick vid in comments
Post by: mdotstrange on January 28, 2016, 03:12:56 AM
No prob  :)

Hmm thats a weird one- outside of some other state/fsm modifying the value- something to do with cameras maybe can't say-
Title: Re: why are my variables changing when I hit play? quick vid in comments
Post by: upOwlNight on January 28, 2016, 03:31:18 AM
I figured it out! The camera HAS to be set to orthographic is seems. It spawns my object on the Z depth of the camera, even in ortho mode, but in the corder of my actual screen resolution. 
 
I think I really need to look into the 2D settings of unity since I'm making a 2D game, but I'm scared.