Playmaker Forum

Bug Reporting => PlayMaker Bug Reporting => Topic started by: barlstreg on January 08, 2017, 06:56:59 AM

Title: Action Browser disappeared[SOLVED]
Post by: barlstreg on January 08, 2017, 06:56:59 AM

I've got a litle problem.

One day (2 days ago), when I started my personnal project the play maker windows were already there. But When I click on the "Action Browser" window it disappeared in the second.
Then I triied to recall it by clicking on the button on the Playmaker windows then nothing. I choosed it by selecting it by the PlayMaker menu... nothing...

i've got 3 screen and it was on the left screen. I tried to restart the project, restart the PC but nothing do... I triied to make the default layout of unity but nothing apened.

So I'm blocked there . All my FSM in the scene runs well but I can't open the "Action browser" for changing my FSM...

Any Idea?

(Working on the Unity 5.2.2F1)

Title: Re: Action Browser disappeared
Post by: jeanfabre on February 07, 2017, 12:55:55 AM

 ok, so you have one custom action that doesn't render properly.

 can you tell me which package you imported? for example pathfinding or else?

you need to turn off action preview in the action browser, then you can browser safely.


Title: Re: Action Browser disappeared
Post by: CoCo on May 10, 2017, 11:57:29 AM
Hi Jean Fabre.

I have the same thing. I was working when i search in "action browser" set "animator float" and it disappear. Impossible de open in editor window or in state.

Thank you
Title: Re: Action Browser disappeared
Post by: jeanfabre on May 11, 2017, 04:18:57 AM

 I checked both SetAnimatorFloat and GetAnimatorFloat and they both render prperly in the action.

 Basically, when this happens, start again, and uncheck the "Preview" check box in the action browser, this will prevent rendering the actions, and you won't get this anymore, however it would be good to find exactly which action is giving problem,

Are you sure you have the latest version of PlayMaker and that you don't carry the old actions related to Animator?


Title: Re: Action Browser disappeared
Post by: CoCo on May 11, 2017, 05:25:45 AM
Hi jean Fabre.
Thank you. It's fine i reinstall playmaker 1.8.4. And it's fine. Before i try everything and i have the same issue with action browser.
It was a new project when it was crash, haven't old action in animator.
I send you a report if i have problem (everything is perfect since this reinstall and uncheck the "preview").
I don't know if the is an incidence to let open action browser all time?
Really thank for your activity on forum!
Title: Re: Action Browser disappeared[SOLVED]
Post by: jeanfabre on May 15, 2017, 05:14:10 AM

 You are welcome :)


Title: Re: Action Browser disappeared[SOLVED]
Post by: conesofdunshire on July 03, 2017, 11:28:37 PM

I'm having the same issue.

I was typing in "set float value" into the action browser, and halfway through the action browser went blank. Everything else works, but I can't work on FSMs, because there's no action browser now.

I get this error:
InvalidCastException: Cannot cast from source type to destination type.
OnAnimatorUpdateActionEditorBase.EditEveryFrameField () (at Assets/PlayMaker/Actions/Animator/Editor/BaseClasses/OnAnimatorUpdateActionEditorBase.cs:18)
SetAnimatorFloatActionEditor.OnGUI () (at Assets/PlayMaker/Actions/Animator/Editor/SetAnimatorFloatActionEditor.cs:20)
HutongGames.PlayMakerEditor.ActionEditor.OnGUI (HutongGames.PlayMaker.FsmStateAction action) (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionEditor.cs:196)
HutongGames.PlayMakerEditor.ActionSelector.DoSelectedActionPreview () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:589)
HutongGames.PlayMakerEditor.ActionSelector.DoBottomPanel () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:546)
HutongGames.PlayMakerEditor.ActionSelector.DoGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/ActionSelector.cs:158)
HutongGames.PlayMakerEditor.BaseEditorWindow.OnGUI () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/BaseEditorWindow.cs:72)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

I followed instructions (from a post from Feb 2017 that looked identical to my situation) of getting the Pathfinding package from the Ecosystem, but it's made no difference. I did move a prefab to a new folder, as it was sharing one with another prefab that had the same material, and this brought my action browser back briefly, but it disappeared again as soon as I started typing in it.

I'm working through M Dot Strange's Playmaker tutorial, Lecture 49, if that helps at all.

Any help would be appreciated.
Title: Re: Action Browser disappeared[SOLVED]
Post by: jeanfabre on August 25, 2017, 05:07:34 AM

 Did you managed to get to the bottom of this ( sorry for the late reply, going through back logs...)