Playmaker Forum

Bug Reporting => PlayMaker Bug Reporting => Topic started by: caesarhernandez on August 02, 2017, 06:22:57 PM

Title: Horrible bug in[SOLVED]
Post by: caesarhernandez on August 02, 2017, 06:22:57 PM
Playmaker editor window will not show anything. I keep getting these errors:

UnityException: SetLogCallbackDefined is not allowed to be called during serialization, call it from OnEnable instead. Called from ScriptableObject 'FsmEditorWindow'.
See "Script Serialization" page in the Unity Manual for further details.
UnityEngine.Application.add_logMessageReceived (UnityEngine.LogCallback value) (at C:/buildslave/unity/build/artifacts/generated/common/runtime/ApplicationBindings.gen.cs:531)
UnityEngine.Application.RegisterLogCallback (UnityEngine.LogCallback handler, Boolean threaded) (at C:/buildslave/unity/build/Runtime/Export/Application.cs:41)
UnityEngine.Application.RegisterLogCallback (UnityEngine.LogCallback handler) (at C:/buildslave/unity/build/Runtime/Export/Application.cs:17)
HutongGames.PlayMakerEditor.FsmDebugger..ctor ()
HutongGames.PlayMakerEditor.FsmDebugger..cctor ()
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for HutongGames.PlayMakerEditor.FsmDebugger
HutongGames.PlayMakerEditor.FsmEditorWindow.Initialize () (at Assets/PlayMaker/Editor/FsmEditorWindow.cs:87)
HutongGames.PlayMakerEditor.BaseEditorWindow.OnGUI ()
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags
Title: Re: Horrible bug in
Post by: caesarhernandez on August 02, 2017, 06:30:24 PM
When I close the window, run the game, stop the game, then open the window again , it works. but after I run the game again with the playmaker editor window open, everything disappears and I get the errors.
Title: Re: Horrible bug in
Post by: Alex Chouls on August 02, 2017, 06:31:46 PM
What version of Unity are you using?
Try resetting the Layout to Default and then re-open Playmaker.
Also double-check that you have the right version of Playmaker for the version of Unity (e.g., Update in the Asset Store while running that version of Unity, then import).
Title: Re: Horrible bug in
Post by: caesarhernandez on August 02, 2017, 06:34:50 PM
Ok that worked. When I ran "check for updates" from unity, it said "up to date", but the Asset Store let me update to latest version. Thanks!