Playmaker Forum

PlayMaker Help & Tips => PlayMaker Help => Topic started by: azunitynoob on November 28, 2018, 11:10:54 AM

Title: Photon Network v1.91[SOLVED]
Post by: azunitynoob on November 28, 2018, 11:10:54 AM
Where do I download it from? The Photon v1.92 is on the asset store. Not v 1.91
Title: Re: Photon Network v1.9.1
Post by: LordHorusNL on November 28, 2018, 12:30:48 PM
If you download Photon Unity Networking Classic from the asset store (v1.9.2) and then download the PUN actions from the ecosystem it should work just fine.

Are you having any problem getting this to work?
Title: Re: Photon Network v1.9.1
Post by: azunitynoob on November 28, 2018, 12:47:06 PM
Are you having any problem getting this to work?
Yes. It doesn't work just fine. Unfortunately. When you go to add a global transition/custom events to a State nothing is listed for photon.
Title: Re: Photon Network v1.91
Post by: LordHorusNL on November 28, 2018, 01:57:27 PM
Yep i tried a new install and can indeed replicate this error.

Here is a temporary workaround, go to: Playmaker>Addons>Photon Networking and click "Set Up Photon Networking"

Hit "Main Menu" and then "Add Photon System To Scene"

This adds the proxy to your scene and gives access to the transitions/custom events.

There does seem to be a problem with the menu however, but i believe an update for this package is in the works.

Hope that does the trick.
Title: Re: Photon Network v1.91
Post by: azunitynoob on November 28, 2018, 02:19:46 PM
Yep i tried a new install and can indeed replicate this error.

Here is a temporary workaround, go to: Playmaker>Addons>Photon Networking and click "Set Up Photon Networking"

Hit "Main Menu" and then "Add Photon System To Scene"

This adds the proxy to your scene and gives access to the transitions/custom events.

There does seem to be a problem with the menu however, but i believe an update for this package is in the works.

Hope that does the trick.

Awesome that worked! Thank you.
Title: Re: Photon Network v1.91
Post by: jeanfabre on November 29, 2018, 05:16:58 AM
Hi,

 I updated the package so that it doesn't warning anymore, 1.92 is supported and works fine.

 Bye,

 Jean
Title: Re: Photon Network v1.91[SOLVED]
Post by: LordHorusNL on November 29, 2018, 07:05:49 AM
Just a heads up jean, i'm not using this package atm but i tried importing the new version and am still getting this menu error on Unity 2018.3 beta.

(https://i.imgur.com/28tfP2hl.png)
Title: Re: Photon Network v1.91[SOLVED]
Post by: jeanfabre on December 02, 2018, 10:55:58 PM
Hi,

 2018.3 is still a beta so we can't guarantee sanity of your project and PlayMaker behaviour. Please don't use 2018.3 or 2019 in production and sensitive project, you could loose it all. Make sure you backup very often as well ( won't help if there is a breaking change though...)

 I never encountered this though... what version of PlayMaker are you using?

Bye,

 Jean