Playmaker Forum

PlayMaker Help & Tips => PlayMaker Help => Topic started by: rustbucket on May 23, 2013, 06:04:44 PM

Title: itween not tweening after updating Unity to 4.1
Post by: rustbucket on May 23, 2013, 06:04:44 PM
Hello,

I've come across a bit of a problem. After updating to Unity 4 from 3.5 and updating playmaker I can't seem to get any itween actions to happen. For example a move tween will move my game object by the requested amount but there is no animation, it just blinks from one place to the next.

I created a new project and tried an itween and that functioned just fine but something seems to have gone amiss in my updated project. Weirdly the itweens I had in place prior to the update still work but I can't make any new ones.

Anyone had a similar issue?

Thanks, Russell
Title: Re: itween not tweening after updating Unity to 4.1
Post by: jeanfabre on May 24, 2013, 03:12:40 AM
Hi very odd indeed.

 Have you tried to "reimport" all assets? is it still doing it with unity 4.1.3?

bye,

 Jean
Title: Re: itween not tweening after updating Unity to 4.1
Post by: rustbucket on May 24, 2013, 08:51:23 AM
Yup, just updated Unity again yesterday but that didn't do it. Neither did a full "reimport". Other actions seem to be working fine, it's just limited to itween. It makes me think it's not finding the itween library but the console isn't complaining about that. I even tried importing itween from the assets store and that made a total mess.

I'm assuming this is just one of those things that happen... I'm going to try exporting what I need as a package (level architecture and some player scripts) and starting with a fresh project to see if that resolves the issue. I was just hoping there might be some more obvious things to try.




Title: Re: itween not tweening after updating Unity to 4.1
Post by: jeanfabre on July 01, 2013, 11:14:00 PM
Hi.

 if you could send me a project that I can repro, I will have a look. Pm me.

bye,

 Jean