playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mTruly

Pages: [1] 2 3 ... 7
1
Feature Requests / Re: Blank Empty Space 'Filler' Action
« on: May 26, 2016, 06:32:33 AM »
Thanks very much for the ideas!  I will try the Comment Action.

(Don't really have scripting skills at this point).

Thanks again.

2
PlayMaker Help / Re: Touch to Send Mouse Input?
« on: May 04, 2016, 08:50:50 AM »
Thanks very much for the info!

I am using an asset from the Asset Store to do something and this asset is only setup to use mouse input.  It is working fine but doesn't accept touch input.  That's why I was trying to get touch to send mouse input.

As my coding skills are nil... I will probably have to look for another asset which accepts both mouse and touch input.

Thanks again.

3
PlayMaker Help / Re: Touch to Send Mouse Input?
« on: May 02, 2016, 11:14:22 AM »
Any ideas on this?

I need to send mouse events with touch.  Can Easy Touch do this?  Can other assets do this?

Thanks!

4
PlayMaker Help / Touch to Send Mouse Input?
« on: April 28, 2016, 10:07:39 AM »
I have read numerous threads on this but I'm not sure exactly whether Playmaker has what I need built-in or I need to purchase additional assets.

I have a setup which uses some scripts to orbit the camera around a hero object. 

1.  When the user drags the R-mouse button... the camera orbits around the hero object.

2.  When the user scrolls the mouse wheel... the camera zooms in or out.

3.  When the user drags the M-mouse button... the view target moves thus panning the camera.


Now I want to implement touch controls to do these same things and it would be easiest if the touch could simply send mouse input.  I would like to have a finger drag send the R-mouse input.  I would like to have a pinch send the mouse-wheel input.  I would like to have a two-finger drag send the M-mouse.

Are these all possible with the standard Playmaker tools or should I look at something like Easy Touch for this?

Thanks for any ideas!

5
Feature Requests / Blank Empty Space 'Filler' Action
« on: April 26, 2016, 12:51:45 PM »
There are times when I would like to have an empty blank 'Filler' action which I could drag and drop into the State action list so I could visually organize groups of actions together for easier understanding when looking at the list.

This empty gray bar would be the same color as the gray on the title bars of actions and would be draggable and deletable, etc and would just give some visual space between actions.

It would visually change this:

Action Name
Action Name
Action Name
Action Name
Action Name
Action Name
Action Name
Action Name


to this:

Action Name
Action Name
Action Name

Action Name
Action Name

Action Name
Action Name
Action Name

Thanks!

6
PlayMaker Help / Particle System Emit Issues
« on: April 26, 2016, 11:08:34 AM »
Unity 5.3.4f1/PM 1.8

I'm trying to use the Particle System Emit action to control emission of particles... but it's not working for me.

If I have a simple scene where the particle system emission is set to 1 per second and the PM Particle System Emit action is set to 10.

When in Editor mode the stream of particles move along in a straight line (a cone emitter with 0 angle) but when in PLAY mode the particle stream disappears and there are some particles created on the base of the emitter but they don't look like 10 per second (it's hard to tell as they're no longer moving and all bunched up).

Does the Particle System Emit action work with the latest Unity particles?


All this brings up larger questions.

The Unity particle system has many settings and I'm wondering what the state of Playmaker action support of these settings is?  It seems only some of the settings are controllable by PM actions?

Are there other actions available that support Unity particles more?

Are other particle systems better supported via Playmaker?  (I have TCparticles and it has some Playmaker actions but the asset itself has been buggy and doesn't seem to be supported very well).

Thanks for any ideas!

7
PlayMaker Help / Re: Particle System Speed Action Problem
« on: April 26, 2016, 10:55:00 AM »
I copied and edited the script but it doesn't really give me the visual results I need and I'm not sure I understand what it's doing so for now I'm sticking with the Particle System Speed action.

Thanks again.

8
PlayMaker Help / Re: Particle System Speed Action Problem
« on: April 26, 2016, 08:25:28 AM »
Thanks very much for this info!

I will give it a try.

Thanks again.

9
PlayMaker Help / Re: Particle System Speed Action Problem
« on: April 25, 2016, 01:20:51 PM »
Unity 5.3.4f1

OK, back to particles speed.


In a simple Unity scene with a particle system with an FSM on it and a single action - Particle System Speed...

If I have the Particle System 'Start Speed' set to 1 and in the Particle System Speed action I have the 'Speed' set to 5... when entering game mode, the particles move at a much faster rate (5 vs 1) as expected/desired.

But if I have the Particle System 'Start Speed' set to 0 and in the Particle System Speed action I have the 'Speed' set to 5...... when entering game mode the particles don't move at all.  I would have expected them to move at the speed of 5... just as before.

If I have the Particle System 'Start Speed' set to .1 and in the Particle System Speed action I have the 'Speed' set to 5...... when entering game mode the particles move at some slow rate and it isn't 5.  I would have expected them to move at the speed of 5... since it seems like the Particle System Speed action should be totally controlling the speed.

Is the Start Speed and Particle System Speed not the same thing?  Should I have the Start Speed set to a particular value to get consistent results?

The Start Speed is definitely influencing the Particle System Speed in some way.

Thanks for any ideas!





10
PlayMaker Help / Re: Playmaker Errors Issue
« on: April 25, 2016, 12:21:06 PM »
Thanks again for the ideas.

I've got it all sorted now.  Before seeing your answer, I renamed the wacked project PlayMakerGlobals.asset (to back it up) and then just copied over thePlayMakerGlobals.asset from the backup project and since no new variables had been created since the backup... all variables are present once again and there are no errors.  And now the backup is current again too.

Yes, I think you're right that version control is needed... I need to look into that.

Thanks again!

11
PlayMaker Help / Re: Playmaker Errors Issue
« on: April 25, 2016, 10:46:54 AM »
Another thing I wish I'd done now was to name my variable names with either a Local or Global in the name so there would be a way to tell what kind of variable I would need to recreate.

Right now, it says missing variable 'animation_name' and I can't remember what kind it was.

Thanks!

12
PlayMaker Help / Re: Playmaker Errors Issue
« on: April 25, 2016, 10:35:48 AM »
Thanks for the ideas.

******
I need to rant for a minute.

Unity is like a house of cards. It is unlike any other app I've ever used and extremely fragile and stupid in the way that it defines a 'scene' file and 'the project'.

If I am using any other app (let's use 3dsMax as an example) I am working along on my 'project' and MAX automatically saves backup MAX files every five minutes (or at whatever interval I choose).  These MAX files contain the entire project... they are only dependant on the MAX app and plugins.  I myself, save MAX files every ten minutes or whenever I feel like and at most, I loose 10 minutes of work if the machine crashes and the scene file becomes corrupt and won't open.  No big deal, I just re-start MAX and go back to work on my scene using one of the many backups.  I don't have to re-install or re-build the app itself and then try to piece together my scene file.

In Unity, the scene file doesn't contain the 'whole enchilada' and so any changes over in the project folders can hose the entire work effort and cause massive headaches trying to recover from this.

As such, the only way to be truly safe is to backup the whole 'project' by copying the massive folder structure each time you want to do a backup.

Anyway, enough ranting... thanks for listening!
*****


I have a backup of the entire Unity project but it is a couple of days old and I would like to not have to redo that work so I am trying to rebuild the current 'Scene'/'Project' setup.

Playmaker is once again installed and working fine but on my real 'scene' file, all the local and global variables seem to be gone (there is one local and one global variable listed in each FSM).  I realize now they were probably stored in the Playmaker>Resources folder.

(*What would be really nice here is since all the variables one creates to use with Playmaker are so critical... it would be great if they could automatically be backed up outside the Assets folder (it is the Assets folder that is really like the house of cards) so when the user was having to rebuild the frick'n app again and accidentally removed the variables, they could be easily restored).


So let's assume that in my backup project... the variable info is intact.

How do I get the variables from the backup project to the wacked project?

Thanks again.

13
PlayMaker Help / Re: Playmaker Errors Issue
« on: April 25, 2016, 09:35:54 AM »
Sigh...

I don't suppose there is any place where all the PM variables are stored?

I have PM installed and working fine again.  As I open up my real scene... I get lots of errors about missing variables, etc.  When I select an object with an FSM on it and go to look at the setup... it is complaining about missing variables.  When I go to look at the variables tab... there is exactly one variable listed.  All the other variables are gone.

Is there any way to recover the previous variables?

Thanks!

14
Action Requests / Re: Get Animation Time
« on: April 25, 2016, 09:27:10 AM »
Would be nice if this action was added to the Ecosystem.

Thanks!

15
PlayMaker Help / Re: Playmaker Errors Issue
« on: April 25, 2016, 08:14:01 AM »
Thanks very much for the ideas!

I've gotten it partially sorted.  I've got PM itself re-installed and the PM item back on the main menu.

Here's what I did.  I opened a new scene in the same project.  I created a folder called Assets_OFF (outside the Assets folder).  I moved each PM related folder into Assets_OFF.  All the errors went away since now there was nothing looking for PM stuff.

I went to the Asset Store and imported PM again.  It did the first compile and the PM menu was added to the Main Menu.  The Welcome Menu appeared.  (I didn't realize that installing PM is actually a two part process.  When you have imported from the Asset Store... you haven't actually installed PM yet.  You then have to use the Welcome Menu to do the actual install and choose what version of PM you want).  So now, PM itself is installed again.  I then installed the Ecosystem and it works.

So then I started to move the other PM related folders back over from the Assets_OFF folder to the Assets folder.  I moved the PlayMaker Animator folder over and it started compiling scripts and then threw the attached Ecosystem related error.

The Ecosystem is installed and working so I'm not sure why this would error.

Thanks again.

Pages: [1] 2 3 ... 7