playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - aeroW45

Pages: [1]
1
Hello everyone.

I am working on a 2d top down pixel game, everything is still very early in development. A good example of what i am trying to do would be something in the style of 2D Zelda games, such as A Link To The Past or Link's Awakening.

My issues are as follows. How do i make the roof of houses transition into invisible when the character goes inside them, so the character is visible to the player while inside the house? How would i do the same thing if said house has multiple floors? When the player goes inside a house i want to have only the current floor be visible without the need of loading in a new scene. So the character would go inside the house while the roof and floors above transitions to invisible. Then the character would go up the stairs and again the camera would follow without a loading screen and show the current floor.

Eventually i also wanna have underground areas, but i assume the technical aspects of having the camera follow the player underground or up a floor are the same. Since its just the player going from one layer to another, no?

I cant seem to find much information on such a thing? I have read things on camera culling, 2draycast and layers but i cant quite understand it. If anyone could point me in the right direction or give me the basics of making a roof invisible, i would appreciate it.

I am using Unity 2018.2.14.f1, Playmaker 1.9.0.p4. and ProCamera2D.

Thank You.

2
Playmaker Help / State names/Labels NOT showing up. [SOLVED]
« on: October 24, 2018, 02:52:28 PM »
Hello everyone.

I have an issue, i am new to Unity and Playmaker, so i was following the Playmaker tutorial (this one https://www.youtube.com/watch?v=I9VwsVtbgFU ). Eventually when trying the switch i noticed i dont get any labels on the objects. In the example i linked at around 16:55 the example shows the label (in this case "off" on the cube in the game window). But when i tried it, i get no labels on the cube. I search on how to change settings but nothing has worked.

I have checked.

-"Shows State Label In Game View" in the Preferences.
-"Draw Active State Labels" in the PlayMakerGUI.
-"Show State Labels" in the Cube object settings.

But nothing works, when i click play my object has no state labels when playing, the switch itself seems to work but no labels on any state objects. Maybe its a glitch, i don't know. I attached some pictures for reference. I would appreciate any help, thank you.

EDIT: Has been solved. Look below.

Pages: [1]