playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Moza

Pages: [1]
1
PlayMaker Help / Major framerate drop with falling platform
« on: April 09, 2014, 04:58:34 PM »
Hi all,

I'm currently making a simple 2D platformer and I am having a little problem in implementing a simple falling platform mechanic that isn't too heavy on resources. Currently when i have 2 of these platforms next to each other and it requires the player to jump from one to another the framerate drops from 60fps to as low as 13fps.

I have tried multiple methods of creating that mechanic from adjusting the gravity scale once you trigger or collide with the platform, but am currently using the set kinematic 2d action where it turns the setting to off after a wait period of 0.5 seconds, making the platform fall.

Is there any other method possible that wouldn't hit the framerate so hard? Thanks in advance.

2
PlayMaker Help / Basic Play Animation Action help
« on: March 30, 2014, 05:40:22 PM »
I seem to be having the same problem with the Play Animation action. I have a very basic gameobject (a Fish in this case) with an Animation component and 2 animations. One to go up and the other to go down. I have a basic FSM setup using Itween to move the object and a Play Animation action depending on the direction of the movement. However I can't seem to get the animations to switch or be called upon. I have tried many ways and with different gameobjects with animations but I obviously must be doing something wrong.

Ive attached images just to see how I have it set up. Any help will be greatly appreciated. Thank you very much.





3
PlayMaker Help / Animations not playing
« on: March 25, 2014, 08:43:48 PM »
Hi all,

I am very new to Playmaker and seem to be having a problem getting any animations to work when not using the animator component. I'm obviously missing a very basic or vital step but I just set up a couple basic animations 'run' and 'jump' and want to use the Play Animation Action to play them accordingly. The game is just a simple 2D game using the new 2D Unity features.

So basically my Player has the Animation Component with run and jump animations. Run is the default, Play Automatically is also ticked and it still doesnt work. Same for when I use the Play Animation Action.

Any help will be appreciated. Thanks and also well done on an amazing product like Playmaker.


Pages: [1]