playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - NKoufou

Pages: [1]
1
This worked! (turned off both Auto-Load all prefabs in project and in scene). Thanks, I guess we have too many prefabs?

How exactly do these options work? What's the side effect of turning these off?

2
I have 6-7 FSMs, over 1500 prefabs, over 2000 textures, you get the idea....

I assume that playMaker is scanning the project folder? Any ideas for what reason and if I can somehow restrict the folders it's monitoring?

Thanks
Nick

3
Hey,

Has anyone noticed that when the playMaker FSM editor window is open it adds a few seconds delay when pressing play in the editor? I noticed this on both Win and Mac versions of Unity.
Startup time is usually around 3-4 seconds, when the FSM window is open there is a delay of 10-15 seconds. I am currently on version 1.2.1 and my scene has about 6-7 FSMs. The project itself is quite big though, over 2GB and 19000 files.

Any suggestions?
Nick

4
PlayMaker Help / Re: About team licenses
« on: October 27, 2011, 02:51:24 PM »
Did you end up finding out anything more on this?

BTW where could I find a full copy of the license agreement?

5
PlayMaker Bug Reporting / Re: Building player fails on playmaker.dll
« on: June 29, 2011, 02:04:58 PM »
Bloody typical finding the problem minutes after posting in a forum....

So the issue is with Perforce integration, by default all files in the local workspace are set to readonly unless they are open for edit. By changing my configuration to set all files to readwrite the issues goes away. Alternatively you could only set PlayMaker.dll to be readwrite only.

Hope this helps someone in the future.

Nick

6
Hi,

I just introduced playMaker to my project and I encountered the following issue when building the player the 2nd time (the first time I build after playmaker integration compilation and deployment works).

Editor.log snippet:

Code: [Select]
Error building Player: UnauthorizedAccessException: Access to the path "/Users/nkoufou/myproject/myproject/Data/Managed/PlayMaker.dll" is denied.
UnityEditor.BuildPipeline:BuildPlayerInternalNoCheck(String[], String, BuildTarget, BuildOptions)
UnityEditor.BuildPlayerWindow:BuildPlayerWithDefaultSettings(Boolean, BuildOptions)
UnityEditor.BuildPlayerWindow:BuildPlayerAndRun()

Unity version is 3.3 Pro + iPhone Advanced running on a Mac

Any subsequent builds fail and my only option is to remove the PlayMaker folder from my project in order to resume work. Any ideas what might be going on here?

Thanks
Nick

Pages: [1]