playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - AxelG

Pages: [1] 2
1
PlayMaker Help / Re: Int Compare not working
« on: November 20, 2019, 08:37:28 AM »
@ch1ky3n: I removed the less condition and deleted the loop event.
The screenshot was before I made any modification :)

@ransomink: I can't let the float because I noticed that when the video ends, the value for a "10,00333"seconds video is "10" seconds so when I'm comparing it will never reach the real video duration. I loose some precision but not impacting what I wanted to do.

Problem solved anyway, thank you all.
Axel

2
PlayMaker Help / Re: Int Compare not working
« on: November 18, 2019, 04:39:33 PM »
@Chyky3n: Thank you. I wasn't familiar with the "toogle breakpoint" but it helped me solve this problem.

The problem was that at the moment the FSM starts, the compared variables values weren't stored yet, so it was both "0" so equal that caused the instant switch to the next event.
I added a "Wait" action of 1s since all videos will be longer than 1 second.

@djaydino I've attached a screen with my next event state, it is a Next Frame event to avoid loop errors, saw one of your video about it (thanks), is it correctly set up?
I think I must have the "every frame" ticked because when I disable it, even with everything on a different state, the software doesn't detect when the int values are equal.
Maybe I am misusing it?


Also: Is there a way to check for a boolean value and define an event depending on it? I've seen the "bool test" action is that its main purpose or is there something else?

3
PlayMaker Help / Re: Int Compare not working
« on: November 17, 2019, 11:26:44 PM »
Hi Tcmeric,
I tried with an other event and I had the same issue, thanks for the tips anyway.

4
PlayMaker Help / [SOLVED]Int Compare not working
« on: November 17, 2019, 08:45:14 PM »
Hello,

I'm trying to compare an "animated" int to a regular one with an int compare action and I can't make it work.
The action automatically goes to the next event whatever the value is.

Screenshot attached.

Is my setup wrong?

Note: The goal here is to define when a video is finished, I'm using a VideoPlayer get time converted float to int compared to a VideoLenght float converted to int.

5
PlayMaker Help / Re: [Update]Problem to Store a String or UI Text
« on: November 17, 2019, 03:31:45 AM »
@ch1ky3n:

The FSM setup that allow to change the text depends of the current activated panel.
For the string Array, I considered it, but in my project it wouldn't have optimal since some panels don't have text and the text has to be translated too.

@djaydino:

Thanks, the Activated/ deactivate action didn't work, but it hinted me that they was a "remove on exit" on the "add component" action that solved the problem!

Thanks to both of you for your time!

Best,
Axel

6
PlayMaker Help / Re: Problem to Store a String or UI Text
« on: November 15, 2019, 10:59:14 AM »
Hello, I'm updating the topic since I still have some issues with my method.

Still with the same text, I have to display it on a different text object in a different Canvas for screen scaling/ fitting reasons.

The stored text is displayed correctly but a one moment, it switch back to the first text stored even if the stored text correctly set-up.

Here is a video:


I don't understand why.

7
PlayMaker Help / Re: Problem to Store a String or UI Text
« on: November 14, 2019, 07:31:47 AM »
That's quite interesting, thanks a lot Jean.

Best,
Axel

8
PlayMaker Help / Re: Problem to Store a String or UI Text
« on: November 13, 2019, 09:44:33 AM »
Hi Jean,

Thank you, like you said it was a race condition.
For the component, I need it in my setup and as it doesn't support Playmaker, I had to edit the default value to what I wanted and have it launch from there so it run correctly.

I use global variable because I need the values to be shared between objects.
I found a solution, though I'm not familiar with event data where can I learn more from it?

Thanks,

Axel

9
PlayMaker Help / [SOLVED]Problem to Store a String or UI Text
« on: November 12, 2019, 11:01:51 AM »
Udpate:

Hello, I'm updating the topic since I still have some issues with my method.

Still with the same text, I have to display it on a different text object in a different Canvas for screen scaling/ fitting reasons.

The stored text is displayed correctly but a one moment, it switch back to the first text stored even if the stored text correctly set-up.

Here is a video:


I don't understand why.

-----------------------
Hey there,

I'm having issues with the get and set UI Text actions. I'd like to store the Text content of a Text component to display it on an other object's Text component.
I use a Global Variable to store the text but when testing, it kind of work randomly.

First Image:
It's the second panel with a different text from the previous but it display the previous panel text.




Second Image:
The following panel displaying the correct text.


Any idea?

10
PlayMaker Help / Re: Load All Video and Audio
« on: November 12, 2019, 02:18:12 AM »
It worked, thank you!

11
PlayMaker Help / Re: Load All Video and Audio
« on: November 11, 2019, 03:47:22 AM »
Oh I didn’t know that we can specify these type of object there.
Thanks.
I’m trying right now, just to know, how the Asset Path has to be written?
I trying  ‘‘/Folder 01/SubFolder 02’’ and the asset stored line is still on "None".

Best,
Axel

Edit: Added a screenshot attached
Edit2: I added a videoclip into the object type variable (as I've seen for other that had the same problem), it didn't work either. The store result is still "None".

12
PlayMaker Help / [SOLVED]Load All Video and Audio
« on: November 08, 2019, 08:21:32 AM »
Hello,

On my project I'd like to load resources from a folder (mp4 videos and mp3 audio files) so that their ready for usage when the game object owner is activated.

Is there a way to achieve that with PlayMaker? I've heard of the "Resource Load" action but when I choosing the type of resources, I don't find audio or video.

Is there another way?

Note: My project consist on displaying short sequences of video one by one. Without loading all the video at once there is a delay between each sequences.

Best,
Axel

13
PlayMaker Help / Re: Android build Issue
« on: October 24, 2019, 04:36:58 PM »
Hi,
I thought I did delete the Steam elements correctly but didn't.
It was the problem, thanks :)


14
PlayMaker Help / [SOLVED]Android build Issue
« on: October 24, 2019, 07:02:54 AM »
Hello,

I'm encountering issues on the Android export of my Test project.
It seems related to the same Playmaker element but I don't understand what it is.
Everything works fine on the Windows build, no console errors.

Attached a screens with 2 warnings and 3 errors I have after trying to build an apk.


15
PlayMaker Help / Re: Using "Get Key" with Global Transition
« on: October 18, 2019, 08:59:27 PM »
Okay, thanks you both for your help!

Pages: [1] 2