playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sketch

Pages: [1]
1
PlayMaker Help / Re: Prefab 2d velocity problem
« on: June 09, 2021, 10:39:43 AM »
Found a work around!

So, here's the thing, if you're interested.

Wetcircuit, you were right! My normal movement FSM that sets the character walking speed was interfering with the run FSM. I put in an action during run to disable the movement and then reenable it when finished. Seems to work now.

HOWEVER - - This still makes no sense!  :o

These FSM's have been working in conjunction with each other for weeks before suddenly getting in each other's way. I'm still utterly sure that it has something to do with the object's status as a prefab as that is the ONLY thing that changed...

Anyway, all's well that ends well... for now.

Thanks, Wetcircuit for the help!!

2
PlayMaker Help / Re: Rotating character
« on: June 09, 2021, 12:38:49 AM »
I'm very new to playmaker so I might be talking nonsense, but could it work doing a direction check before the apply force, then using different states to apply the force in specific direction?
Use get position and save the z rotation value, save it to a variable. Then do a float compare saying if a value is xxx then apply force at either x/y.

3
PlayMaker Help / Re: Prefab 2d velocity problem
« on: June 08, 2021, 04:22:50 PM »
No worries! Thanks for your help!

Yeah, it seems tagged okay. I've gone through every fsm and can't find anything conflicting. It's weird because when I test it is technically working, the fsm goes through the states just fine, the animation changes, even the velocity change highlights green. It just simply isn't taking effect.
If it's a clue, his walking speed has slowed down a little too so it's certainly got something to do with the velocity in general... Other moving objects seem fine.

4
PlayMaker Help / Re: Prefab 2d velocity problem
« on: June 08, 2021, 01:05:45 PM »
Thanks for the reply!
Yeah, I don't think it is that. The whole run system is triggered by an FSM attached to the player. It refers to USE OWNER to work. I tried targeting it specifically but with no success. It's a weird issue, right? Up to about 2 minutes ago it was running well. No other FSM's or anything target the player's velocity (except for the basic movement).

5
PlayMaker Help / Prefab 2d velocity problem [SOLVED]
« on: June 08, 2021, 12:38:58 PM »
Hi guys,

I don't think this is a playmaker issue but it's my main tool, soooo...

I dragged my character who has several playmaker fsm's attached (movement, jump, run, etc) into the prefab folder. I guess this was a massive mistake or something, because now I have this weird issue where his speed is not being set correctly.
I have a run skill where you hit the direction key twice and he runs (using set velocity 2d). Now, the fsm is working, his animation changes for example, but he isn't speeding up at all. Is this a problem with him now being a prefab? I can't for the life of me work out why this would happen at all. Weirdly, all his other skills (which mostly use force and move rigidbody) all work perfectly. Does anyone have any ideas why isn't this one working?
I'm sure it's something stupidly simple in the prefab settings...
Thanks in advance

6
PlayMaker Help / Re: Timer depleat on button hold
« on: May 31, 2021, 02:26:21 AM »
Hi! Sorry for the late reply - long weekend. This seems to have worked well. Thank you so much!

7
PlayMaker Help / Timer depleat on button hold [SOLVED]
« on: May 27, 2021, 04:08:47 PM »
Hello all!

Very new to both Unity and Playmaker. Surprised by just how much I've been able to pull of with literally no experience. Awesome!

Right now I'm trying to implement a kind of hover system in my 2d game. I'm sure it is very common but I can't seem to find advice for it.

The idea is that the player can hover when they hold the shift key. They can press and hold for more lift or tap it for short bursts. That's all working well already. The issue is that I don't want it to be infinite. I want the player to have about 2 seconds of 'fuel' that runs down as they have the key pressed down. After that they have to hit the ground and wait a while before they can go again.

I can't use wait because then it would be 2 seconds from take off regardless of button lift (and every key press would gain 2 seconds...) , I also need the key down on a loop so it can retrigger if they tap before the fuel is spent. The actual hover works perfectly, its just the running out of fuel bit I can't crack.

I've tried using set time with various times (delta, etc) and using variables, it almost works but not quite. The fuel does run out when the timer hits 2, but I have a problem that it only counts as soon as the button is pressed (I think it's time between frames, not real time) so the player can just fly infinity if they hold the key down.

Would anyone have a solution to this? I'm sure it's an easy one as I've seen it done many times before. By the way, I'm using standard unity controls and physics - really just trying to learn the program.

Pages: [1]