playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mpaul0055

Pages: [1] 2 3
1
PlayMaker Help / Re: Unity 5.5.1 Global Variable Issue
« on: February 24, 2017, 03:38:15 AM »
OK Issue Fixed! Phew!

Playmaker had stored the Playmakerglobal.asset in the Editor/Resources folder, and not in the main Resources folder!

I manually moved the asset file and it all works as expected!

Thanks for your help Jean. Amazing support as always!

2
PlayMaker Help / Re: Unity 5.5.1 Global Variable Issue
« on: February 24, 2017, 01:36:34 AM »
I have tried 32 and 64 Bit builds for the PC, both have the same issue.


3
PlayMaker Help / Re: Unity 5.5.1 Global Variable Issue
« on: February 24, 2017, 01:23:20 AM »
It's a PC build that's causing the issue.

I'll roll back to Unity 5.5.0 and see if that helps. It's good to know it does work in 5.5 so it's clearly a bug or issue with my project.

Have you tried Unity 5.5.1f1?

Thanks

Mark

4
PlayMaker Help / Re: Unity 5.5.1 Global Variable Issue
« on: February 23, 2017, 05:17:36 PM »
I noticed another post where someone had a similar issue with the Xbox one and Unity 5.5. Their fix was to place the PlaymakeGlobals.asset file in the preloaded assets section in the player settings. Unfortunately this did not resolve the issue for myself.

Any Ideas?

----------
Update. I have tested an older scene with Unity 5.4 and PlayMaker works as expected.

5
PlayMaker Help / [SOLVED] Unity 5.5.1 Global Variable Issue
« on: February 23, 2017, 04:01:31 PM »
Hey All

We have recently updated our project to Unity 5.5 and have noticed a a bug which is causing major issues when we build/compile our project.

Inside the editor all global variables work as expected. But once we build the project they simply do not work as expected.

Unfortunately I have tried to roll back our project to 5.4 but our scene file has corrupted in the backup so we are stuck!

Has anyone had similar issues?

Any help would be massively appreciated.

Thanks

6
Hi Alex

What do you think of the above now the trigger does not have any itween actions attached.

The object its activating is a spot light attached to the player.

Thanks

Mark

7
Hi Alex

I thought id make this public in case other users have the same issues.

Ive attached another photo of the profiler which still shows the trigger spike still occurring while not using iTween.

This is using the latest Unity 5.4.0b9, so once we have the beta playmaker I will report back any results.

Thanks

Mark

8
Hi Alex

Ive attached another image of the profiler, but ive just created a simple trigger that activates one game object, and the same spike happens. In fact on this one its 58%.

Im happy to upload the project although it is quite large. We are going to stick with 5.4.0 as its resolved some Culling Performance issues we had with 5.3.3.

9
While the trigger spike is still noticeable in game, its not as prominent, but it is certainly still there. 48% performance hit when you enter the trigger with a 7.8ms spike in profiler.

This is with Playmaker 1.8.0  and Unity 5.3.3p1 & Unity 5.4.0b8

Also, just a heads up, We have this error in 5.4.0b8

SetLogCallbackDefined is not allowed to be called during serialization, call it from Awake or Start instead. Called from script 'FsmEditorWindow' on game object ''.
See "Script Serialization" page in the Unity Manual for further details.
UnityEngine.Application:add_logMessageReceived(LogCallback)
HutongGames.PlayMakerEditor.FsmDebugger:.ctor() (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmDebugger.cs:51)
HutongGames.PlayMakerEditor.FsmDebugger:.cctor() (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmDebugger.cs:22)
UnityEditorInternal.InternalEditorUtility:LoadSerializedFileAndForget(String)
UnityEditor.WindowLayout:LoadWindowLayout(String, Boolean)

10
In the editor, ill test on the phone tomorrow and report back.

11
Thanks Alex.

I thought i had got the latest version installed, but clearly not.

Im now running v1.80, but still getting a physics hit of around 40% when we hit a trigger, and now its every trigger. Not noticeable in low poly areas, but when we are close to maximum performance the dropped frame is very noticeable as you jump about a 2ft down the corridor.

Ive also got another spike thats occurring since updating Playermaker which is GC.Collect. Its spiking at about 85% and ive never seen this before.

Any help would be greatly appreciated.

12
Hi Alex

Im using Unity 5.3.1p and Playmaker 1.7.8.3

Thanks

Mark

13
Hi All

We are in the final stages of optimization for our VR mobile release of Affected.

Im having a few issues with Playmaker and a few of the triggers I have created.

One trigger actually hurts performance by 50% which causes a large drop in frames which is VR has to be avoided.

Ive also noticed that triggers are constantly being called, and even simple ones seem to use about 0.6% while doing nothing, is this a normal behavior?


Ive attached an image as this seems massively excessive. Any advice would be greatly appreciated.

14
PlayMaker Help / Re: Weird Kinematic Trigger Problem
« on: October 20, 2014, 06:55:19 AM »
Thanks so much.. Worked perfectly!

15
PlayMaker Help / Weird Kinematic Trigger Problem [SOLVED]
« on: October 18, 2014, 07:37:30 AM »
Hi Guys

Ive got a simple trigger setup, that when entered it sets "Is Kinematic" off on a number of objects i want to fall to ground.

The problem is when i enter the trigger, the objects stay Kinematic, and the "is kineamatic" action does not work.

But if i bypass the trigger and move the start state forward, the "is Kinematic" actions do work as expected.

Its really stumped me this as it seems like an illogical bug.

All the other actions in that state work fine with the trigger, so it plays all its audio, but will not set the objects to non kinematic.


Pages: [1] 2 3