playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jin

Pages: [1]
1
It can be caused by console errors and other things.

The best solutions list I have found is here on the Troubleshooting page:
https://hutonggames.fogbugz.com/default.asp?W624

Scroll down to "Missing Playmaker Menu"

2
I just solved this. I'll explain how for future searchers.

I decided to reimport Photon and noticed it has upgraded to 1.76

This upgrade didn't solve the missing menu choices, so I clicked:
Playmaker menu/Addons/Photon Networking/Setup Photon Networking
to open the Photon Setup Wizard. (Here I noticed that upgrading gave
me a warning from Playmaker that they currently only support 1.75
and I don't believe the upgrade solved the issue.)


On the Photon Setup Wizard the server was set up properly but the scene wasn't
so I clicked it. I also clicked both the component buttons.
After that the PHOTON menu I was posting about now exists.

-Jin

3
PlayMaker Help / No PHOTON menu choices with Photon installed.[SOLVED]
« on: October 02, 2016, 11:39:04 PM »
Hi again.  8)
I am hoping another set of eyes can help with this oddness.

I am using Unity (64bit) 5.4.0f3,  Playmaker 1.8.3,
and the Playmaker PUN 1.75 for Unity 5 with
Photon Unity Networking Free 1.75

I am currently following Romi's tutorial step by step.
I am on Part 3:
At 14:30 (
he shows to add a global transition to a state by clicking
Global Transition/ Custom Event/ PHOTON/ Joined Room,
BUT in my editor the PHOTON menu is not available under
Custom Event or anywhere else.

Can anyone suggest why that is?

Thanks! Jin

4
PlayMaker Help / Re: missing actions, but action script exists in project
« on: September 30, 2016, 12:49:58 AM »
Okay, here's a lil update for the benefit of anyone searching about this in the future.

I seem to get quirky errors related to the order which I import the assets:
Playmaker, Photon, Playmaker PUN, and Easy PUN setup.

I noticed in this thread: http://hutonggames.com/playmakerforum/index.php?topic=13502.0
that Jean says "for Unity 5, you need to download photon from the asset store first and then download the package from the Ecosystem."
so I started over with a new test project, and
1) imported  Playmaker 1.8.3
2) then imported Photon Unity Networking Free 1.75
3) then  imported Ecosystem.unitypackage and
4) used Ecosystem to download Playmaker PUN 1.75 for Unity 5
5) then imported Easy PUN setup

This order got rid of those "missing action" errors in the easy PUN FSMs
but then the console errors from this thread:http://hutonggames.com/playmakerforum/index.php?topic=13545.0 appeared....

"Assets/PlayMaker/Actions/RunFSMAction.cs(138,30): error CS0115: `HutongGames.PlayMaker.Actions.RunFSMAction.DoParticleCollision(UnityEngine.GameObject)' is marked as an override but no suitable method found to override

Assets/PlayMaker/Actions/CollisionEvent.cs(119,34): error CS0115: `HutongGames.PlayMaker.Actions.CollisionEvent.DoParticleCollision(UnityEngine.GameObject)' is marked as an override but no suitable method found to override

Assets/PlayMaker/Actions/Physics2D/Collision2dEvent.cs(100,30): error CS0115: `HutongGames.PlayMaker.Actions.Collision2dEvent.DoParticleCollision(UnityEngine.GameObject)' is marked as an override but no suitable method found to override"


Which also makes the Playmaker menu disappear.
So I reimported Playmaker 1.8.3 from asset store downloads list.
This fixed all errors for now and the Playmaker menu is back.

Quirky business but worth a try if you are stuck.
I hope this helps someone sometime.

-Jin



5
Hi, this is confusing me now and is a bit different
from my last post about missing actions.

I am using Unity (64bit) 5.4.0f3,  Playmaker 1.8.3,
and the Playmaker PUN 1.75 for Unity 5.

I have a issue with "easy PUN setup" FSMs that show
an exclamation mark error "missing action" but the
action script exists in the playmaker PUN actions folder.

Any idea why the scripts are no longer associated with the nodes?

6
PlayMaker Tutorials / Re: Photon Networking with PlayMaker Tutorial
« on: September 18, 2016, 06:39:24 PM »
Very helpful tutorials!

Thanks very much!

-Jinn

7
PlayMaker Tutorials / Re: How to make simple custom Playmaker actions
« on: September 18, 2016, 06:37:46 PM »
Awesomeness!

Thank you.

-Jinnn

8
PlayMaker Help / Re: multiple errors about missing actions
« on: September 13, 2016, 01:22:45 AM »
Unity (64bit) 5.4.0f3 and Playmaker 1.8.3 and yes a fresh project.

However, after ecosystem came back up I followed your advice
from the other thread to get the playmakerPUN.package there,
and the "missing actions" errors are gone now.

Thanks!

9
PlayMaker Bug Reporting / Re: Error after updating Photon to 1.75
« on: September 13, 2016, 01:18:21 AM »
Thanks! that worked to get rid of that error.

I was unable to access ecosystem all weekend,
but I appreciate your reply and I am happy
that ecosystem is working again too.

10
PlayMaker Bug Reporting / Re: Error after updating Photon to 1.75
« on: September 12, 2016, 12:47:18 AM »
Thanks for your detailed answer.
I followed your instructions and did load DemoWorker
without the error from this thread showing up.

When I pressed play though, it didn't work and I saw
many errors show up referring to "missing actions"

I started a new thread about that here:
http://hutonggames.com/playmakerforum/index.php?topic=13547.msg62984#msg62984

Thanks again for trying to help.

11
PlayMaker Help / [SOLVED]multiple errors about missing actions
« on: September 12, 2016, 12:44:07 AM »
In following the instructions in this thread:
http://hutonggames.com/playmakerforum/index.php?topic=13491.msg62979#msg62979
I managed to open DemoWorker with a whole list of new errors
that refer to "missing actions."

I have seen "missing actions" before in my experimenting with
"Easy PUN Setup" and can't figure out what causes this.

Any ideas or links would be appreciated.

12
PlayMaker Help / Re: Unity 5.4.0 error message with PUN
« on: September 11, 2016, 09:03:44 PM »
I second this. I have the exact same issues going on.

13
PlayMaker Bug Reporting / Re: Error after updating Photon to 1.75
« on: September 11, 2016, 04:15:24 PM »
I am glad that is working for you. I assume you are importing PlayMakerPUN.unitypackage as well?

I just followed those instructions with the addition of PlayMakerPUN.unitypackage
and still have the error whether I open DemoWorker-Scene  or DemoWorkerGame-Scene

It's a fresh project with fresh install of playmaker 1.8.3 and photon v.1.75 with those Git folders copied and pasted over as described.

I only see one error:

Assets/PlayMaker PUN/Scripts/PlayMakerPhotonGameObjectProxy.cs(83,29): error CS0019: Operator `!=' cannot be applied to operands of type `PhotonMessageInfo' and `null'

Anyone who has had experience getting rid of the error, I would appreciate advice.

Thanks, Jin

14
PlayMaker Bug Reporting / Re: Error after updating Photon to 1.75
« on: September 10, 2016, 02:13:46 AM »
Hi All!
I am attempting to add PUN to my game using "Easy PUN Setup Playmaker".
I cannot test/compile due to this error:

Assets/PlayMaker PUN/Scripts/PlayMakerPhotonGameObjectProxy.cs(83,29): error CS0019: Operator `!=' cannot be applied to operands of type `PhotonMessageInfo' and `null'

I am using Unity 5.4.of3 Personal (64bit) and Playmaker 1.8.2
I have attempted reimporting. I also purged all related files and
reinstalled. As well I tried the github suggestion in this thread.
No success so far. I feel stumped. Any other ideas?

Thanks, Jinnn

Pages: [1]