playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - therewillbebrad

Pages: [1]
1
PlayMaker Help / Re: Missing Action after asset update
« on: May 11, 2020, 04:06:04 PM »
Comparing the old actions to the new custom actions provided in the asset the new ones seem to be using a namespace instead of doing the using DarkTonic.Coregamekit;

Core game kit is also located in the plugins folder so not sure if the namespacing could be triggering the errors, but that's definitely all thats changed with the actions. Also weird that the action browser can see the actions.

2
PlayMaker Help / Re: Missing Action after asset update
« on: May 11, 2020, 03:29:49 PM »
This is with the latest version of playmaker btw.

3
PlayMaker Help / Missing Action after asset update
« on: May 11, 2020, 03:29:20 PM »
Updated the asset coregame kit and I get 100s of errors because I relied on fsms that interacted with this asset.

The issue is it's saying missing action when I can see the action in the action browser. Is there something I'm missing to get these fsms to recognize these actions?

4
PlayMaker Help / Re: Prefab variable changed when game is played
« on: December 21, 2019, 05:07:59 PM »
Bumping to hopefully get a better solution to this.

5
PlayMaker Help / Re: Prefab variable changed when game is played
« on: November 25, 2019, 08:04:13 PM »
I'm thinking I've isolated the issue to copying game objects that have fsms in them. I'm assuming it still has a reference to the original fsm pre copy that is messing with things. The current way I've been fixing these errors is to make a new game object and copy the fsm in to a new fsm and that breaks whatever connection is happening.

6
PlayMaker Help / Re: Prefab variable changed when game is played
« on: November 25, 2019, 04:37:08 PM »
I'm also having this same issue. I'm thinking at the moment it has something to do with copying the fsms from another prefab and then reusing them. Because it will start changing completely disconnected prefabs. 

7
PlayMaker Help / Re: Trying to fix build errors
« on: June 12, 2019, 12:35:56 AM »
So that didn't fix it. Could pre processing the fsms be causing it? Or is this something to do with the new prefabs? Would there be any reason some fsms are working while others aren't? This is 2018.4 btw.

8
PlayMaker Help / Trying to fix build errors
« on: June 10, 2019, 02:53:43 AM »
Trying to narrow down what is causing my build to be screwy and wondering if it's this playmaker error that I can't pin down.

Assertion failed on expression: 's_AssetProgressBar.dialog'
UnityEditor.PrefabUtility:SaveAsPrefabAsset(GameObject, String)
HutongGames.PlayMakerEditor.ProjectTools:DoPreprocessPrefabFSMs() (at Assets/PlayMaker/Editor/PlayMakerProjectTools.cs:90)
HutongGames.PlayMakerEditor.ProjectTools:PreprocessPrefabFSMs() (at Assets/PlayMaker/Editor/PlayMakerProjectTools.cs:57)
HutongGames.PlayMakerEditor.PlayMakerPreProcessBuild:OnPreprocessBuild(BuildReport) (at Assets/PlayMaker/Editor/PlayMakerBuildCallbacks.cs:27)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)


Thanks for the help.


9
PlayMaker Help / Ecosystem browser error 2018.1
« on: July 03, 2018, 03:29:59 PM »
Hi I can't seem to get the ecosystem working in 2018.1 here's the error I keep getting.

`EditorCoroutine.routine' is inaccessible due to its protection level
error CS0122: Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/Tools/ProjectScanner/ProjectScanner.cs(208,40)

`EditorCoroutine' does not contain a definition for `startManual'
error CS0117: Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/Tools/ProjectScanner/ProjectScanner.cs(205,60)

Any help would be greatly appreciated as I need some custom actions off of there.
Thanks!

10
User Showcase / Re: Apex Path Actions for Playmaker
« on: March 20, 2018, 02:54:16 AM »
Any updates on this I am very interested.

Pages: [1]