playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - indeed

Pages: [1] 2 3 ... 6
1
PlayMaker Help / How to set rotation based on speed?
« on: February 19, 2021, 12:01:11 PM »
Hi, I have a situation where I'm translating cylinders of different sizes, like wheels, across a plane manually. Each cyl is moving at a random but constant speed.

But right now they're not rotating, just translating.

My physics/math skills are weak and I'm not sure if there's a way in playmaker to rotate the cylinders at the right speed so they 'roll' without seeming to slide across the floor plane. Any advice?

2
Action Requests / Re: Set Fog Mode?
« on: January 21, 2021, 05:31:18 PM »
Thank you!

3
Action Requests / Set Fog Mode?
« on: January 21, 2021, 12:25:20 PM »
Hi would it be possible for someone to make an action that would allow for setting the Fog Mode as Linear, Exponential, and Exponential Squared? https://docs.unity3d.com/ScriptReference/FogMode.html

4
Feature Requests / Re: FSM relationship screen/window
« on: January 21, 2020, 09:44:32 AM »
Yes, agree, this would be great.

5
PlayMaker Help / Re: Array values not updating when using Get Next
« on: September 02, 2019, 01:41:28 PM »
I found a way to make this work, but is this how it's supposed to be? In the "Next" state, if I add an "Array Set" action that assigns the current index value to the "Result" variable, then it correctly stores it in the array. See screenshot.

6
PlayMaker Help / Re: Array values not updating when using Get Next
« on: September 02, 2019, 09:24:44 AM »
Ah, that's the method I've used the most often. It actually works here with other kinds of operations. For example, if instead in the Next state I use "Array Set", the array correctly updates to the value I choose using the index number. It's as if it can correctly talk to the index number but not the stored variable from the array "Result".

7
PlayMaker Help / Re: Array values not updating when using Get Next
« on: September 02, 2019, 12:27:07 AM »
Sorry I'm confused. Making an an Array variable in the Variables tab of an FSM doesn't create an array?

8
PlayMaker Help / Re: Array values not updating when using Get Next
« on: September 01, 2019, 11:49:57 PM »
Oh, maybe this is the issue.... There is no component. I just created an array within playmaker variables. Am I supposed to manually add a component to the Game Object?

9
PlayMaker Help / Re: Array values not updating when using Get Next
« on: September 01, 2019, 11:18:06 PM »
Sure, here is a screenshot of the setup showing the next state

10
PlayMaker Help / Array values not updating when using Get Next
« on: September 01, 2019, 02:16:56 PM »
Hi I can't get array values to update and I'm just curious if this is a known issue. I've tried with an Int array and a Bool array. Changes made using Array Get Next (set all bools to True, or Add 1) do not update the values in either array. And I don't think it's a Unity display issue because the scene also reacts to the new values as if they're unchanged. I tried adding the "Array Save Changes" action between every step with no effect.

You can see in this screenshot that curiously the value (+1 added to an Int of 0) updates in the "Result" variable but not in the array itself. Apologies if I'm missing something obvious.

Unity 2018.2.19f1
Playmaker 1.9.0 p18
OS X 10.14.5

11
PlayMaker Help / Re: "Get Scene Is Loaded" errors
« on: July 16, 2019, 10:55:02 AM »
Hi I'm having this exact same issue. Also, Get Scene Is Loaded doesn't seem to correctly identify any scene properties. For example it will send an "Is Loaded" event based on a scene name that doesn't exist. Any ideas?

12
Action Requests / Action to set Particle Velocity?
« on: July 02, 2019, 03:07:59 PM »
Hi I'm looking for an Action that can set the "Velocity Over Lifetime" property of a Particle System. Does that already exist somewhere? I didn't see anything on ecosystem.

13
PlayMaker Help / Re: Set Property for legacy particle system broken?
« on: July 02, 2019, 02:01:24 PM »
Hi thanks for the reply. I've mostly resolved this issue. Yeah the issue is with Unity 2018's near total deprecation of the legacy particle system and Playmaker's inability to "see" it in 2018 Unity. They key is to use Unity 2017.4 or earlier, where Playmaker can still see the Legacy Particle properties, and then use the tool that djaydino linked to.

14
PlayMaker Help / Re: Set Property for legacy particle system broken?
« on: June 29, 2019, 11:11:01 PM »
Hi thanks for the reply I'll look into it!

15
PlayMaker Help / Re: Set Property for legacy particle system broken?
« on: June 28, 2019, 10:06:13 AM »
Hi sorry to bump this but the project is a bit time-sensitive. It would even be useful to know if this is simply no longer possible.

Also it's easy to test: Just drag an Ellipsoid Particle Emitter component into an FSM state to Set Property. The properties are not listed.

Pages: [1] 2 3 ... 6