playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qholmes

Pages: 1 ... 4 5 [6]
76
PlayMaker Help / Copy Template file does not work
« on: July 05, 2011, 07:52:29 AM »
I deleted a FSM by mistake yesterday... And continued on working for a bit before i noticed.. decided to undo as it was not a little simple one but not crazy either.. But unity crashed when i was undoing for some reason.. so i opened my latest backup folder and made a template from the original one and saved it.. I then copied the template file over to my current project folder and it does not work??? Why is that? Does it have local folder references or something?

I am going to try and rename the root folder but i dont understand how this will make templates work when i go to use them in other projects? Is this not possible?

Q

77
PlayMaker Help / Animate Variable using unity animation
« on: July 04, 2011, 11:01:15 AM »
I use Unity animation files to animate my objects.. It allows me to create scripted movie like animations for auto demonstration mode... I then have my controls and animation playing run through playMaker.. But it would be handy sometimes to be able to animate a variable directly in a Unity Animation file.. Is there a way to do this?

I currently have a slave object that i animate the x,y and z values and then read them into variables... works pretty good but i was thinking of a more streamline approach..

I did see that i can trigger events with the animation editor which is cool but i dont see the ability to pass data to variables?

Is any of this possible?

How could i expose a variable to the animation editor?

Q

78
PlayMaker Help / camera fade
« on: June 17, 2011, 12:27:39 PM »
I have a camera that is just a small overlay image section... if i use the camera fade it fades the whole screen not just the cropped viewport rect.

Is there an easy way to fade that camera in and out?

Q

79
In my Layout config that i use for playMaker i have the Actions panel set to be under the Inspector on the right side..

If i set Maximize on Play on then i get NullReferenceException:Object reference no set to an instance of an object
UnityEditor.DockArea.OnGUI()

If i switch to another layout it works fine and if i just close the Actions panel it works fine too..

Q

80
PlayMaker Help / variables in inspector
« on: April 27, 2011, 12:10:29 PM »
Is there a way to have variables editable in the main Inspector? I would swear that i saw that somewhere when i was going through examples but cant find it.

Q

81
PlayMaker Bug Reporting / Playmaker GUI [FIXED]
« on: April 26, 2011, 09:58:19 PM »
I was having issues of multiple references to the PlayMakerGui script. If i deleted an extra one then it would tell me i dont have a reference to a script.

What i did i think was add one manually which in the docs or tutorials says you can do..... But when i would do that it would do its automatic thing at the same time and i end up with two... So i ended up deleting them all and then when i either opened the file again or clicked on a GUI object it would realize it needed one and would put one in.... Then all was good.. I deleted my old GUI ones as they seemed to be referencing a script that i had deleted or something.

82
PlayMaker Help / Playmaker GUI
« on: April 25, 2011, 09:40:13 PM »
I am working on a Global Timer so that i can run scripted animations for my project ( a product demo app). I decided on this approach so that i can access a global timer value and have FF and RW and Pause Play buttons to run through the many different sequenced events... i hope i am not crazy on this..

Anyway I have been fiddling with PlayMaker GUI stuff for a few hours and can not get it to work. When i add a GUI button it adds the PlayMakerGUI script to my object and also to the root of the Hierarchy... Then i get a warning that there should only be one instance of the PlayMakerGUI but if i delete one then i get an error that a reference script does not exist or something like that..

I am adding my button to my main camera just like in the tutorial.. But it tells me that my object needs a collision object or a GUI component to work... so i put on a GUI Texture and the error goes away.. The buttons seem to do something but if i make a basic Mouse Down transition and then a Mouse Up transition it does not work.. The transitions do not do anything... i wanted to have it that when i pressed my button the Timer value that i am displaying FF or RW.

I did get it to almost do something if i did a Finished transition on my FF State but it was so fast that it barely FF at all unless i ramp up the value to a crazy number because it is only flashing once to my FF state not cycling on it like i want.

I am 100% sure i am just doing something basic wrong but after hours of reading and messing around i can just not get it to work...

Q

83
PlayMaker Help / GUI Text Box
« on: April 22, 2011, 08:40:35 PM »
So i am going to try and make a GUI Text Box.. I am quite amazed that there is not one in there already.. i thought for sure that GUI Box or GUI label were going to be but not so.. I just want that exact function but with the text inside the graphic with text wrapping and maybe adjustable border.

I am brand new but do you think it will be possible to create that by tearing apart the existing GUI Box action?

or it might be easier to just use EZ Gui to make the box and then just fire it using playMaker? The boxes are pop up information boxes that will be used while moving around an object. I did not want to have to create all custom images for the boxes but use live text instead.

Q

84
PlayMaker Help / Install Playmaker
« on: April 21, 2011, 12:10:18 PM »
Ok i just purchased Playmaker and imported it into my project but it did not show up in my menus anywhere.... so i tried moving the files around to where i thought they should go like i had to do with iTween before and maybe another one... not sure why they dont move to the proper folders but anyway... I am new to Unity and still dont quite understand these things..

So i moved them around and now i have a menu item under Component but nothing else.. And my EZ GUI menu item is now gone. And i have a conflict with iTween...

Any ideas?

I did do a search on the Unity Forum and Answers and here..

Q

Pages: 1 ... 4 5 [6]