playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - DennisJensen

Pages: 1 [2] 3 4 ... 7
16
PlayMaker Help / Re: Array loops starts at 0 first time, 1 second time?
« on: December 15, 2017, 07:25:21 AM »
So I just created a new example, where do the following:

1. Set a index int to 0
2. Run through a loop X amount of times based on array, debug by outputting the index int number (Using "Array Get Next")
3. Pressing a key to reset

And that works.

So I redid my scoreboard loop.

1. I set index to 0
2. I run through my scoreboard array using "Array get next"
3. I compare the new score to the score in my array, if it's higher then proceed.
4. If the score is higher then save the index as the placement for our new highscore. Using "Set int" PlayerSpot_I = PlayerIndex_I (PlayerIndex_I is the index variable i use in the array get next.

I don't use my PlayerIndex_I anywhere else than these three states but somehow it outputs 0 the first time you run it. and then 1 the second time even though both are new highscores.

Can it be something with the array not updating the new score that I input?

This is what happen, my score is 0, 0, 0 for top 3, I set a score at 100 and the score becomes 100, 0, 0. Then I replay the game and sets a score at 120 which then gives me 100, 120, 0 but only if I replay it from the same game scene, if I reload the game scenes it works. It's so weird.

17
PlayMaker Help / Re: Array loops starts at 0 first time, 1 second time?
« on: December 15, 2017, 03:11:21 AM »
I see the index 0 at the second picture?

Yes, so I run from the event save score, and I set the index int to 0 before running the array get next. So it should be set to 0, however it doesn't when I run save score for the second time. It's so weird.

18
PlayMaker Help / Re: Array loops starts at 0 first time, 1 second time?
« on: December 15, 2017, 02:28:58 AM »
As far as i know, you don't need to change variables and the reset will do the trick.

Okay, I just tried using the get array 2 from ecosystem, it has a reset flag which I set to true, but it gives me the same error.

I attached the issue. I really can't figure it out :/ Same how it starts at 1 the second time I run through it. I could try with array lists instead but I dont see how that should solve it, and its a bit of work to change all my variables.

19
PlayMaker Help / Re: Array loops starts at 0 first time, 1 second time?
« on: December 15, 2017, 02:08:11 AM »
@krmko

Okay, there is also a Array Get Next on the ecosystem with a restart bool, so I might try that first so I don't have to change my array variables :) But that might do the trick.

20
Hey Guys,

I gotten a lot of help in this forum, and once again I'm back with a new challenge :)

I created a leaderboard for our game KnightOut. When the game is over it add's a score to our leaderboard based on how good the score is. It will place it at spot 0 if its a new highscore. And it works completely when I run it the first time. The second i run it, if the player wants to restart, time the "Array Get Next" action starts at index 1 instead of 0? The range is set to 0-9 and I change nothing when I run it. It doesn't make sense.

This means even if I get a new highscore it will place it under the number 0, because it starts checking from 1, instead of 0, which screws up the whole system.

Any ideas?

21
Action Requests / Re: Steam / Steamworks.net / Steam SDK
« on: October 30, 2017, 02:06:00 AM »
Very helpful thank you so much :)

22
Action Requests / Steam / Steamworks.net / Steam SDK
« on: October 27, 2017, 02:28:49 AM »
Hey Guys,

I wanted to ask if anybody worked with this or created actions for it? I really think it's something that is needed, since a lot of games are going to steam and it increases your changes of being seen.

I know there are some actions, but they seems a bit buggy. Here is the link:
http://hutonggames.com/playmakerforum/index.php?topic=8464.msg72165#msg72165

We are going to use it for our game as well. So we are really interested in getting this working somehow. I haven't looked into the actions yet though.

23
PlayMaker Help / Re: Player goes through the floor
« on: September 27, 2017, 08:10:26 AM »
Thank you,

I think we have plenty of stuff right now we need to look into, since the game is also launching soon on steam in closed Alpha :)

24
PlayMaker Help / Re: Alternative to XML xPath / Porting to consoles
« on: September 27, 2017, 08:09:40 AM »
@jean

No worries we will figure it out :)

25
Share New Actions / Re: Rewired (polling) Actions
« on: September 27, 2017, 06:26:20 AM »
Hey Guys,

So I looked at the example files how to assign joysticks based on button press.

Does this work with playmaker actions as well? Since I'm unable to find the joystick.GetAnyButtonDown

I would like to use this in a way where the player presses "A" and then joins, but it can be two players on keyboard and two on joysticks.

Cheers
/Dennis

26
PlayMaker Help / Re: Alternative to XML xPath / Porting to consoles
« on: August 25, 2017, 01:17:25 AM »
Sorry about the slow response, we are going to showcase our game at PAX so there is a lot at the moment.

We tried to choose full .net 2.0 but with no result, we still get the same error.

I will see if I can get a answer from MS, I just wrote them a email.

Cheers

27
PlayMaker Help / Re: Player goes through the floor
« on: August 25, 2017, 01:01:03 AM »
@Terri
Yeah that could also be a solution, but currently we don't see the bug anymore, which is great :) So I don't think we need to do that.

Regarding the smoke trail, yes that's something I have been thinking about too. Thanks for the input.

28
PlayMaker Help / Re: Player goes through the floor
« on: August 21, 2017, 02:52:40 AM »
We just had a weekend filled with testing and lowering the max fixed timestep solved the problem since now it can't skip a frame, however if it does lag the whole game is in slow motion :) So we just need to keep it optimized :D

29
PlayMaker Help / Re: Alternative to XML xPath / Porting to consoles
« on: August 15, 2017, 07:38:31 AM »
Sorry about the late reply.

I been so busy. This is the error that we get.

I will test it out as with Nintendo as soon as we get the dev kit, but it sounds promising, I was worried I had to rewrite it all.

30
PlayMaker Help / Alternative to XML xPath / Porting to consoles
« on: August 10, 2017, 01:12:49 AM »
Hi guys

We been using dataMaker XML, and we just tried for fun if we could port our game to X Box.

We didn't think about this, but it makes sense that you can't store a XML file, it also gives a error about the xPath. It's a issue since we store progress and unlucks using XML files. Is there a alternative? In my mind we could maybe just use plain text, but would the xPath then work? Or do I have to do something differently entirely?

Also we are going to port the game to Switch, and in my mind it's going to be the same problem.

Pages: 1 [2] 3 4 ... 7