playMaker

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PaulH

Pages: 1 [2] 3 4
16
Share New Actions / Re: UnityAds
« on: December 10, 2014, 10:56:42 AM »
Can you please include the completed video rewards??

yes i'm also in need of the actions for this, if anyone can help?

17
Unity Services / Re: Unity Ads
« on: December 10, 2014, 10:47:10 AM »
Check out the post by cloud03

http://hutonggames.com/playmakerforum/index.php?topic=8311.0

What I do is stop inputs and then show the ad with the engine being paused. Then when the engine is unpaused I wait a fraction of time and then turn inputs back on.

could i ask one more favor? do you know how i check if the user actually finished watching the video ad? because as it is now in my game, the user watches the vid (using the 2 actions we have available init and show) and then once finished i give the reward on the next state. I do it this way because i don't know how to set up the reward system in unity ads.

but...my problem is, if the user (on ios) hits the home button on ipad/iphone etc while the ad is playing and then starts the app straight back up, they cut the ad off and then get the reward without actually watching it. I just need to do a quick check to see if they actually finished the ad so i can then proceed to give the reward if they did, if not then i dont.

i found this onVideoCompleted(String itemKey, boolean skipped) but i dont know how to implement it.

Thanks in advance for your help.


18
Unity Services / Re: Unity Ads
« on: December 08, 2014, 01:26:25 PM »
np, I'll be adding allowPrecache, isInitialized, isShowing and isSupported actions as well as a separate isReady/show ad action when I get time.

Hi LampRabbit

did you ever do the other actions you mentioned above? i could really use them now. especially the isInitialized, because i noticed if there is a slow internet connection while unity ads are being initialized, it can almost crash your game if the user tries to play it at the same time they are being initialized.

so i would like to be able to check if in fact they are initialiezed before the user can play.

cheers.

19
Feature Requests / Re: Unibill Support / Actions For In App Purchases
« on: November 22, 2014, 12:00:39 PM »
I'm waiting for this too ! :)

if you would like to have actions for unibill please vote for them here (on the 'wish list'):

https://trello.com/b/1VSKPLcT/addons

thanks

20
Hi all

I would like to request a full set of actions for the cross platform In App Purchase plugin Unibill

https://www.assetstore.unity3d.com/en/#!/content/5767

If this would be a good addition for you, please click the following link and vote for it in the 'wish list' on trello.

https://trello.com/b/1VSKPLcT/addons

Many Thanks

Paul

21
you're most welcome!

22
bump for an answer... 

24
Hi,

 this needs a lot more debugging and profiling to pin point exactly what the problem is.

Likely, in most case, it's not really the trigger that is the issue but more what's being done when a trigger is fired.

 Have you profiled it?

 Typically, I would create a dummy prefab, and simply remove all actions apart from the trigger event leading to an empty state, not even logging anything. do you witness a spike still?

 Bye,

 Jean

Hi Jean

The same as the other person said regarding this problem, its just the 'first' time these events happen that is the problem, i dont think it is anything in my game, its the actions themselves, or something in playmaker (i think, although of course i could be wrong)

Because the second (third fourth fifth...etc) times these events happen, the 'exact' same actions are used on the 'exact' same objects in the 'exact' same way but there is nowhere near the same spike.

i 'have' profiled it and the spike is caused 99.9% by physics simulate - playmaker onTriggerEnter collisionEnter the first time they are used...why?

the second, third ...etc times these events happen it is roughly 70-90% less of a spike on the exact same objects with the exact same actions.

i know you are busy jean, but please don't leave it days before answering, i really need to get a fix for this.

many thanks

Paul

25
Hi Alex or Jean

please can you tell me if anything is going to be done about this?

This issue was first reported a while ago and so its obvious im not the only person experiencing this.

Its nothing to do with the pool its playmaker onAwake and playmaker onCollision/onTriggerEnter that's the problem.

cheers,

Paul


26
PlayMaker Help / Re: Expected top level layout group missing!
« on: September 19, 2014, 03:27:54 PM »
That's reassuring to know, jess84. And it's useful to know Daikon Forge is a performance-hog. We're only targeting PC and Mac for now, so fingers crossed we'll be okay.

hi
as far as im aware daikon forge gui is no more! its been taken from the asset store already and i don't think dfgui 2 will ever be released.

Takuan thinks because of uGUI its over for all other gui devs, so hes called it a day, but is thinking about releasing the source.

my advice stay away from DFGUI i had nothing but nightmares with it, went over to NGUI still had nightmares but no where near as bad!

hope this helps.

27
Hi,

Is your pool prefilled before the scene starts? what pooling system are you using?

 typically, some pool are filled at runtime and you get a spike for each new pool item, and other pools gets prefilled at editor time which means no spike at all.

 Bye,

 Jean

hi Jean,

i use coregamekit for the pooling. The pool is loaded/filled before the game starts, but when an item from the pool is activated/used for the first time it spikes, but the second time after its been deactivated and reactivated it doesn't.

also the first collisions/Triggers cause a spike. Then when that object collides for the second time (after despawning and re-spawning) its fine.

if i restart the game after playing it (after all these things have already happened for the first time, using the 'restart level' action) its fine and plays smooth with no spikes at all. The problem is playmaker onAwake, onCollisionEnter etc according to the unity profiler.

If there was some way to make all this happen as the game starts/loads it would eliminate this problem.

or is there something wrong with those actions themselves?



28
when activating game objects (through pooling etc) on IOS for the first time, i get a big FPS spike. It only happens the 'first time' an object is activated, then when i deactivate and reactivate its fine.

Also first time collisions etc cause a major spike, then there after no problem, just the first ones. I have found from using the profiler this is down to playmaker.

Is there any way around this? a way to have all this happen before on startup so it doesn't happen mid game? because this does cause a major problem in my game, i have tried everything to get rid but with no luck.

regards,

ps maybe an action that lets you list the objects you need preloading for all this to happen and preloading into the GPU?

29
PlayMaker Help / Re: OnAwake, OnEnter and Playmaker
« on: September 17, 2014, 06:45:15 AM »
bump

to get an answer?

30
PlayMaker Help / Re: OnAwake, OnEnter and Playmaker
« on: September 16, 2014, 05:43:59 AM »
did anything ever happen with this? i have the same problem.

when activating game objects (through pooling etc) on IOS for the first time, i get a big FPS spike. It only happens the 'first time' an object is activated, then when i deactivate and reactivate its fine.

Also first time collisions etc cause a major spike, then there after no problem, just the first ones.

Is there any way around this? a way to have all this happen before on startup so it doesn't happen mid game? because this does cause a major problem in my game, i have tried everything to get rid but with no luck.

regards,

ps maybe an action that lets you list the objects you need preloading into the GPU?

Pages: 1 [2] 3 4