playMaker

Author Topic: how to not show the gui elements labels [SOLVED]  (Read 1443 times)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14059
  • Official Playmaker Support
    • View Profile
how to not show the gui elements labels [SOLVED]
« on: February 16, 2012, 03:41:02 AM »
Hi,

 I just can't find the settings or preference to remove the label on all the gui stuiff I create.

 very odd. Any hint would be most appreciated!

 Bye,

 Jean
« Last Edit: February 29, 2012, 11:26:47 AM by Alex Chouls »

netlander

  • Playmaker Newbie
  • *
  • Posts: 13
    • View Profile
Re: how to not show the gui elements labels
« Reply #1 on: February 16, 2012, 04:18:36 AM »
Hi Jean,

I remember coming across this issue in the past:

To disable the drawing of active state labels there is an option in the PlayMakerGUI object that's created by PM in your scene. Click on the object and in the inspector you'll find a few flags and one of them says "Draw Active State Labels", so the theory is if you uncheck this flag you will not see the labels when you run your game.

However, it has proven to be unreliable at times as I recall not being able to hide the labels even after I uncheck this flag. In that case I remember going through the objects in my scene that have FSMs and in the inspector untick "Show State Labels"for each FSM for those objects.

Hope this helps
Paul

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3581
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: how to not show the gui elements labels
« Reply #2 on: February 16, 2012, 04:49:10 AM »
Usually if unchecking "Draw Active State Labels" doesn't work, it means you have a second PlayMakerGUI in the scene by accident. PlayMakerGUI draws the state labels. I'll add some checks when editing PlayMakerGUI settings...

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14059
  • Official Playmaker Support
    • View Profile
Re: how to not show the gui elements labels [SOLVED]
« Reply #3 on: February 17, 2012, 04:24:38 AM »
Ok,

 It was just a miss in the guilayoutlabe action. There is a "else" missing between the two blocks. It will be fixed in 1.3.1

 Bye,

 Jean

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3581
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: how to not show the gui elements labels
« Reply #4 on: February 17, 2012, 08:30:20 AM »
1.3.1 is now in the asset store...