playMaker

Author Topic: ugui bug?  (Read 1489 times)

thefonz

  • Playmaker Newbie
  • *
  • Posts: 24
  • Augmentititus
    • View Profile
ugui bug?
« on: September 17, 2015, 08:06:04 AM »
hi guys

im getting an error when importing the ugui proxy. has anyone had this issue before?

unity 4.6.3
playmaker 1.7.8.3

error:
Assets/PlayMaker Custom Actions/uGui/EventSystem/GetLastPointerEventData.cs(221,96): error CS1061: Type `UnityEngine.EventSystems.RaycastResult' does not contain a definition for `worldNormal' and no extension method `worldNormal' of type `UnityEngine.EventSystems.RaycastResult' could be found (are you missing a using directive or an assembly reference?)

any help will be much appreciated.

thanks

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15321
  • Official Playmaker Support
    • View Profile
Re: ugui bug?
« Reply #1 on: September 17, 2015, 11:34:26 PM »
Hi,

It's likely a glitch, I would try to delete script and reimport it to force unity to refresh somehow

if that doesn't work: Could you try on the latest 4.6.8?

else get back to me.

Bye,

 Jean

thefonz

  • Playmaker Newbie
  • *
  • Posts: 24
  • Augmentititus
    • View Profile
Re: ugui bug?
« Reply #2 on: September 18, 2015, 06:31:53 AM »
Hi Jean

ill give that a go this weekend and let you know what happens. ive tried it on a fresh scene also and it still wont work..

ive also tried loading the scripts from the ecosystem and the standalone files provided on the wiki.

thanks

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15321
  • Official Playmaker Support
    • View Profile
Re: ugui bug?
« Reply #3 on: September 21, 2015, 06:43:19 AM »
Hi,

 let me know how it goes.

 Bye,

 Jean

thefonz

  • Playmaker Newbie
  • *
  • Posts: 24
  • Augmentititus
    • View Profile
Re: ugui bug?
« Reply #4 on: October 04, 2015, 02:59:51 PM »
just wanted to confirm this issue is fixed when using unity 4.6.8

danila_dem

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: ugui bug?
« Reply #5 on: October 11, 2015, 08:21:25 PM »
hi
I have the same problem
http://take.ms/dnQrN

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15321
  • Official Playmaker Support
    • View Profile
Re: ugui bug?
« Reply #6 on: October 16, 2015, 06:52:43 AM »
Hi,

 on 4.6.8?

 Bye,

 Jean