playMaker

Author Topic: Badseed Tutorial Help Please.  (Read 1592 times)

KingLlama

  • Playmaker Newbie
  • *
  • Posts: 12
Badseed Tutorial Help Please.
« on: October 24, 2015, 01:19:36 AM »
I've finished the tutorial and my AI wanders if i'm far if I don't connect with the AI but when I connect with the AI and the AI chases it doesn't lose range/sight and while he is doing that the AI attacks with each cycle.

These are the Tutorials I was using. Can anyone help? I also am using UFPS.

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 6495
    • jinxtergames
Re: Badseed Tutorial Help Please.
« Reply #1 on: October 24, 2015, 05:00:07 AM »
Hi,
Do you have the link to that tutorial?

Is that tutorial using UFPS.
I have not used UFPS but it might conflict.
have you tried the tutorials without UFPS?

maybe some actions are set wrong, if you can't find the problem can you add some picture or vid so maybe we can see what is wrong.
the more information you give, the easier it is for us to find the problem :)
Ecosystem might not work at the moment
here are direct Github Links to the custom actions :
https://github.com/PlayMakerEcosystem
https://github.com/jeanfabre


Join the PlayMaker Discord Channel!

KingLlama

  • Playmaker Newbie
  • *
  • Posts: 12
Re: Badseed Tutorial Help Please.
« Reply #2 on: October 27, 2015, 01:37:00 AM »
Here is the tutorials
I also made a video showing each part of my script with what is happening while ingame. It's a long video but you can speed it up.

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 6495
    • jinxtergames
Re: Badseed Tutorial Help Please.
« Reply #3 on: October 27, 2015, 03:14:48 AM »
Hi,
it seems that the "Radar Shut Off Switch" fsm is the problem.
It disables the orientation / range finder / Angel Detector before the bool are set to false. so all the bools stay true.
the easiest way i think is to add "set fsm bools" in the off state to set them to false.

also i noticed that @ 1:49
the "Set Value" is both the same on the states "Hit Player" and on "Didn't Hit Player"
Ecosystem might not work at the moment
here are direct Github Links to the custom actions :
https://github.com/PlayMakerEcosystem
https://github.com/jeanfabre


Join the PlayMaker Discord Channel!

KingLlama

  • Playmaker Newbie
  • *
  • Posts: 12
Re: Badseed Tutorial Help Please.
« Reply #4 on: October 28, 2015, 12:36:51 AM »
So I noticed that If I get close he goes into idle and gets stuck when trying to pursue but if I go a certain distance he will start moving closer toward me and then once he does, he stops at a certain distance away from me.
I didn't know how to set the set fsm bool correctly. So, please correct me if I am wrong. I did fix the hit player/didn't hit player problem to a degree.


I'm still testing but at about 25 distance he starts to move forward but as soon as he gets closer then that he loses it.
« Last Edit: October 28, 2015, 12:56:15 AM by KingLlama »

KingLlama

  • Playmaker Newbie
  • *
  • Posts: 12
Re: Badseed Tutorial Help Please.
« Reply #5 on: October 28, 2015, 01:16:40 PM »
So, I found the problem but I'm going through things trying to fix it now. Part of the problem was that in range finder the store result for get distance was supposed to be both store result distance but I had one threshold and the other distance. Next is that the target itself isn't being recognized but the player visible isn't correctly working now.