playMaker

Author Topic: Triggers never seem to work  (Read 1529 times)

Byromaniac

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Triggers never seem to work
« on: November 22, 2015, 01:11:43 AM »
I've tried everything I can think of. The tags are all correct and I've tried it w and w/o rigidbodies, but no my triggers never seem to work properly. They are spotty if working at all. ATM I have objects spawning randomly around a plane and to avoid objects being placed in the same spot, I just wanna destroy it if it hits the trigger, and yet it just just doesn't seem to recognize the trigger..am I doing something wrong?

ivam

  • Playmaker Newbie
  • *
  • Posts: 34
    • View Profile
Re: Triggers never seem to work
« Reply #1 on: November 22, 2015, 02:36:54 AM »
are you sure the object moving into the trigger has a collision box?

dudebxl

  • Hero Member
  • *****
  • Posts: 602
    • View Profile
Re: Triggers never seem to work
« Reply #2 on: November 22, 2015, 06:43:36 AM »
... and a Rigidbody
« Last Edit: November 22, 2015, 06:55:35 AM by dudebxl »

redikann

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: Triggers never seem to work
« Reply #3 on: November 22, 2015, 08:05:29 AM »
Did you check "Trigger" on the physics component. Did you create a separate layer for the trigger and then change what layer the trigger can detect in Edit>Project Settings>Physics

Byromaniac

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Triggers never seem to work
« Reply #4 on: November 22, 2015, 08:37:45 AM »
Yup they have a box, and Rigidbody. I did not try changing the layer. Currently its on the default. I'll try that

Byromaniac

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Triggers never seem to work
« Reply #5 on: November 22, 2015, 09:00:32 AM »
Tried changing layer and settings. No luck. Works when I code it out, just wanna use playmaker cuz I basically stumble my way through coding. lol

Byromaniac

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Triggers never seem to work
« Reply #6 on: November 22, 2015, 11:31:54 AM »
worked when I turned off gravity....

Justin

  • Junior Playmaker
  • **
  • Posts: 58
    • View Profile
Re: Triggers never seem to work
« Reply #7 on: November 23, 2015, 06:48:47 PM »
Are you spawning objects into the trigger? If so, try using both onenter, and onstay.