playMaker

Author Topic: Errors after upgrading to PM beta  (Read 7287 times)

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: Errors after upgrading to PM beta
« Reply #15 on: December 14, 2015, 07:38:18 PM »
Project #4.
No warnings.

I did the same thing as project #3 and got the same results.   You have to update all FSMs in the build to get rid of the warnings.  Otherwise, you get them after playing the game every time.

Project #5
Can't test.  I spent 1.5 years working on this full time and lost the global variables 3 months ago.  Bummer.  there were hundreds of them.  I had to delete off the playmaker stuff to install a new version.  O well.

I'll load in a old 1774 version and upgrade it.  I'll send you the errors.

wheretheidivides

  • Sr. Member
  • ****
  • Posts: 496
    • View Profile
Re: Errors after upgrading to PM beta
« Reply #16 on: December 14, 2015, 09:11:35 PM »
OK, here are errors in the console.  I had 1.772P2 and upgraded to 1.80RC37.  This comes from a project that doesn't have much in it.  There were 53 errors.  I had to delete everything related to playmaker and then reload the project and then install 1.8 RC37 fresh.  Then there were no errors.  If you need the project I can zip and upload.  it's just a demo right now.

Assets/PlayMaker/Actions/SetFsmVariable.cs(98,32): error CS0115: `HutongGames.PlayMaker.Actions.SetFsmVariable.AutoName()' is marked as an override but no suitable method found to override

Assets/PlayMaker/Actions/iTween/iTweenMoveTo.cs(63,38): error CS0115: `HutongGames.PlayMaker.Actions.iTweenMoveTo.OnDrawActionGizmos()' is marked as an override but no suitable method found to override

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3643
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Errors after upgrading to PM beta
« Reply #17 on: December 14, 2015, 10:04:54 PM »
Can you email me the project before you import the update?

From the errors it looks like there are probably duplicate playmaker dlls after updating and Unity is still using the old one, not the new one...

But if I have your project I can see what happens exactly...

« Last Edit: December 14, 2015, 10:12:59 PM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3643
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Errors after upgrading to PM beta
« Reply #18 on: December 15, 2015, 03:45:53 PM »
Thanks for sending me the project.

It turns out the project had duplicate Playmaker dlls from a previous import. This was an import problem with Unity 5.0-5.2. It should be fixed in Unity 5.3.

To fix duplicate Playmaker dlls:
- BACKUP your project
- Delete Assets\Plugins\PlayMaker\PlayMaker.dll
- Rename Assets\Plugins\PlayMaker\PlayMaker 1.dll to PlayMaker.dll

You should then be able to import the 1.8.0 beta.

I'll add this setup problem to the Auto Updater so it can handle this automatically.


« Last Edit: December 15, 2015, 03:52:20 PM by Alex Chouls »