playMaker

Author Topic: Using action "Play Sound" volume is really quiet[SOLVED]  (Read 5807 times)

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Using action "Play Sound" volume is really quiet[SOLVED]
« on: June 07, 2016, 03:24:48 AM »
When I attach an audio source to a gameobject, the volume works correct, but if I play a sound through a "Play Sound" action or "Audio Play", the volume is really quiet, even though I have volume at 1.
I'm new to Playmaker so not sure if I miss something basic.

Im using Unity 5.3.4p3
« Last Edit: February 23, 2017, 05:28:26 AM by jeanfabre »

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #1 on: June 07, 2016, 03:35:13 AM »
Ok, I narrowed down the issue:
I have a state that has the following actions:

- Audio Play (or "Play Sound" doesn't really matter)
- Send Event
- Get Owner
- Destroy Object

In this case the volume is really quiet, but if I create an intermediate state with just the "Audio Play" (and a FINISHED transition to the other state), the volume is fine. If I instead use "Play Sound" the issue persists.

Can somebody let me know why this happens? I would prefer to have everything in one state, instead of having to create intermediate state just for the audio.
« Last Edit: June 07, 2016, 03:49:35 AM by christianstrang »

Gida

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #2 on: June 07, 2016, 03:57:34 AM »
How do you play the Sound and which Version are you on?  :)

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #3 on: June 07, 2016, 04:10:50 AM »
I'm using Unity 5.3.4p3 and I play the sound using the action "Audio Play" (though I have the same issue with "Play Sound"

4ppleseed

  • Full Member
  • ***
  • Posts: 227
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #4 on: June 07, 2016, 04:43:28 AM »
I have this problem too. Since switching to U5, the audio is really quiet using Play actions

Gida

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #5 on: June 07, 2016, 04:48:11 AM »
Problem is since V5 there is the option of the playing a "3D" Sound. Now the Volume depends on the Distance to the Listener i think. Since then there is the audio Mixer:

http://docs.unity3d.com/Manual/AudioMixer.html

You can try to uncheck the 3D Option there.

Or:  Create an empty GameObject with a FSM. Make a global event. Then attach the "Play Sound" Action to it. Start Runtime and press "Alt" + "LMB" on the Event..

This should sound loud and clear.
« Last Edit: June 07, 2016, 04:50:38 AM by Gida »

Gida

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #6 on: June 07, 2016, 04:53:57 AM »
Sorry I was wrong. In U5:

MAke an empty GameObject and just import the Sound via Drag and drop to the scene. Attach  it to the GO as a child and deactivate it (the sound file).

Now you can activate it and it shall sound equally loud.

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #7 on: June 07, 2016, 05:11:01 AM »
That seems to be working. I don't really like this solution though, as it complicates something that should just work.

I wasn't able to find an option to deactivate the 3d sound (I work with a 2d project, is it automatically deactivated there?). Could you let me know how to deactivate it, I would rather just use the "Play Sound" action without having to create a child gameobject that gets activated.

Gida

  • Playmaker Newbie
  • *
  • Posts: 48
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #8 on: June 07, 2016, 05:20:59 AM »
try in the import settings. I know its not the best solution but the quickest way around. You can try and attach your Sound source close to the Audio Listener??

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #9 on: June 07, 2016, 07:22:15 AM »
I'm not sure where to change it for the import settings (please see the attachment) I tried mono but that didn't help.

Quote
You can try and attach your Sound source close to the Audio Listener??
I'm not sure what you mean by that, as I work in the 2d space, I'm not sure if this even applies to my situation.

dudebxl

  • Hero Member
  • *****
  • Posts: 602
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #10 on: June 07, 2016, 08:37:30 AM »
Anybody tried playaudio advance on ecosystem?

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #11 on: June 07, 2016, 09:19:18 AM »
I gave it a try and it didn't help with the sound issue, though for my situation it would be overkill anyway. The default play audio or play sound would be fine for my 2d-situation, if I could only increase the volume for it (the volume is fine if I don't use a playmaker gameobject).

dudebxl

  • Hero Member
  • *****
  • Posts: 602
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #12 on: June 07, 2016, 10:06:36 AM »
Ok,cool... But as side note, with the action you can set the sound to 2d and you can control most the audio source elements. I had this problem and it was solved when you set audio source to 2d.

christianstrang

  • Playmaker Newbie
  • *
  • Posts: 16
    • View Profile
Re: Using action "Play Sound" volume is really quiet
« Reply #13 on: June 07, 2016, 11:09:52 AM »
You are right, setting the spatial blend to 0 makes it 2d and then it works. This is actually a great alternative, considering you can just use the action without creating an additional gameobject that has to be set to active. A bit overkill for what I need, but will probably stick with it, thank you for the suggestion! :)