playMaker

Author Topic: Playmaker All Actions Missing after Gameplay Testing  (Read 872 times)

Teco

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Playmaker All Actions Missing after Gameplay Testing
« on: July 08, 2016, 06:09:31 AM »
Title sums it up in a nutshell but basically if I launch Unity, go to the action browser in FSM, they are all there. But after pressing play and testing my game, they are all gone. All I get is 'Missing Action' under the Debug mode. Please Help!
Thanks,

Teco

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Playmaker All Actions Missing after Gameplay Testing
« Reply #1 on: July 08, 2016, 08:34:07 AM »
Can you submit a bug report so we get more info on unity version, playmaker version etc.

Are there any other errors in the console besides the "missing action" errors?

artician

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 298
    • View Profile
Re: Playmaker All Actions Missing after Gameplay Testing
« Reply #2 on: August 12, 2016, 10:43:57 AM »
I just encountered this same issue.  Yikes.

Any word on a fix? I'm on Uv5.3.5, and PMv1.8.1.

Edit- I've reinstalled PlayMaker several times.  Deleted anything generating errors.  No change. 

Edit- This might be related to removing unrelated (?) project folders.  I deleted several folders from my project prior to this happening.  PlayMaker recovered its actions when I restored the deleted files. 
One of the deleted elements was Koreographer, which has some PlayMaker actions included with it, but none of these files or folders were part of the main PlayMaker directories. 
I can verify that nothing from any of the PlayMaker folders or AddOns was touched, but maybe external tools modify something I'm not aware of.  Would love to know more about this.  PlayMaker never generated any errors during this issue.

Thanks in advance for the help!

« Last Edit: August 12, 2016, 11:01:33 AM by artician »