playMaker

Author Topic: [SOLVED] Get child not working unity 3.5 + playmaker 1.3  (Read 7319 times)

evilzed

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
[SOLVED] Get child not working unity 3.5 + playmaker 1.3
« on: February 16, 2012, 09:30:58 AM »
Already had a project everything was working fine. I upgraded Playmaker through asset store overwriting old version then upgraded unity. Now everything still works as it should except the get child function all the gameobjects which I try to store the child in are empty once the state with the function is left.

I tried using get child function with tag or name and both same result. Thanks for any help.

EDIT

Currently to work around the issue I'm using the old get child script searching by tag and it is working fine.
« Last Edit: May 09, 2012, 09:36:38 AM by Alex Chouls »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #1 on: February 16, 2012, 03:11:37 PM »
Sorry, a bug snuck in there!

You can also use the version here:
http://hutonggames.com/playmakerforum/index.php?topic=918.0

Will fix this in 1.3.1

evilzed

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #2 on: February 16, 2012, 03:20:54 PM »
No worries, I believe get child num action has the same bug.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #3 on: February 17, 2012, 08:31:21 AM »
Thanks!

1.3.1 is now in the asset store, and fixes these bugs.

yurgalavage

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #4 on: February 17, 2012, 09:22:56 PM »
Already had a project everything was working fine. I upgraded Playmaker through asset store overwriting old version then upgraded unity. Now everything still works as it should except the get child function all the gameobjects which I try to store the child in are empty once the state with the function is left.

I tried using get child function with tag or name and both same result. Thanks for any help.

EDIT

Currently to work around the issue I'm using the old get child script searching by tag and it is working fine.

man i wish i had read this before i was banging my head against a wall last night until 3am trying to figure out why my fsm's werent working right any longer when i updated to 1.3.0.    i used the old script after reading this last night and it fixed it.  i will give 1.3.1 a go a little later-

when stuff 'should' work and doesn't i will remember now to check here first and/or post bugs myself if it's not listed.

best,
Mike

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #5 on: May 07, 2012, 01:41:53 PM »
Hi guys
I´m in v 1.3.3
I´m having the same problem. Get Child isn´t giving me the game object.
Look
Please help me.
Bye

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #6 on: May 07, 2012, 02:48:54 PM »
I just tested here and it works fine... are you sure you don't have a typo?

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #7 on: May 07, 2012, 02:51:21 PM »
When I run my game it doesn´t get it.
I´m gonna continuing trying.
Bye

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #8 on: May 07, 2012, 03:00:47 PM »
In Game Object- the parent
Child Name-        because it depends
With Tag- "Untagged" because it depends
Store Result-"Child GO" game object variable
It´s never gets it.

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #9 on: May 07, 2012, 03:17:11 PM »
Quote
Child Name-        because it depends

Get Child finds a child by Name - you have to enter a Name.

If you just want the first child, use Get Child Num with Child Index 0.

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #10 on: May 07, 2012, 03:39:56 PM »
Oh ok sorry Alex because I think that was right.
I´m using Get Child Num but it continues not working.
Bye

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #11 on: May 07, 2012, 03:53:47 PM »
I just tested it here and it works okay...

Can you post a screenshot of your hierarchy?

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #12 on: May 07, 2012, 04:06:27 PM »
I´m sorry Alex
But it´s isn´t function here
Look
It should says "M4 na mão".
Bye

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3637
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #13 on: May 07, 2012, 04:13:09 PM »
Can you post a screenshot of the action?

Dev_Sebas

  • 1.2 Beta
  • Sr. Member
  • *
  • Posts: 398
    • View Profile
    • Blog
Re: Get child not working unity 3.5 + playmaker 1.3
« Reply #14 on: May 08, 2012, 08:36:50 AM »
Accidentally today after wake up I play the my game just for fun and it workings.Now is fine.
I think sometimes the things aren´t made for that moment.
Thanks for your time Alex.
Bye