playMaker

Author Topic: Updated to 1.8.2: PlayMakerEditorUtils.cs, '...is obsolete' compile error  (Read 3663 times)

NateGallardo

  • Playmaker Newbie
  • *
  • Posts: 31
    • View Profile
I've updated two different unity projects to Unity 5.4 and PlayMaker 1.8.2 in the last few days. One went fine once I removed the duplicate scripts that have since been integrated into Playmaker, but the other is giving me a few compile errors.


Assets/PlayMaker Utils/Editor/PlayMakerEditorUtils.cs(102,94): error CS0618: `HutongGames.PlayMakerEditor.FsmEditorUtility.GetActionScriptAsset(HutongGames.PlayMaker.FsmStateAction)' is obsolete: `Use ActionScripts.GetAsset instead.'

Assets/PlayMaker Utils/Editor/PlayMakerEditorUtils.cs(111,90): error CS0618: `HutongGames.PlayMakerEditor.FsmEditorUtility.GetActionLabel(HutongGames.PlayMaker.FsmStateAction)' is obsolete: `Use Labels.GetActionLabel instead.'


Any ideas, team?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Hi,

 I would suggest you clean up PlayMaker in your project and import  again. you may have had some bad merging when installing the update.

Else, the problem could be in another place and when Unity can not compile, other errors popups but aren't the source of the problem. So make sure you look up all errors.

 Bye,

 Jean

NateGallardo

  • Playmaker Newbie
  • *
  • Posts: 31
    • View Profile
Hi Jean,

How should I go about cleaning up PlayMaker in the project? Are there some key folders I should delete and re-import or something?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Hi,

 yes,

--Delete the "PlayMaker" folder
-- Delete inside "Plugins",the "PlayMaker" folder.

 then, you reimport PlayMaker from the Asset store.
 
Bye,

 Jean

NateGallardo

  • Playmaker Newbie
  • *
  • Posts: 31
    • View Profile
I removed all traces of PlayMaker from the project, and then started to re-import it all.

It threw up this error after the PlayMaker installation:

Assets/PlayMaker/Editor/PlayMakerProjectTools.cs(220,115): error CS0618: `UnityEngine.ParticleEmitter' is obsolete: `This component is part of the legacy particle system, which is deprecated and will be removed in a future release. Use the ParticleSystem component instead.'

Which I got around temporarily by commenting out that particular line of code. Obviously not a permanent solution, but it let me continue for the time being.

Then, I downloaded and imported Array Maker from the Ecosystem, at which point it gave me those same original errors again:

Assets/PlayMaker Utils/Editor/PlayMakerEditorUtils.cs(102,94): error CS0618: `HutongGames.PlayMakerEditor.FsmEditorUtility.GetActionScriptAsset(HutongGames.PlayMaker.FsmStateAction)' is obsolete: `Use ActionScripts.GetAsset instead.'

Assets/PlayMaker Utils/Editor/PlayMakerEditorUtils.cs(111,90): error CS0618: `HutongGames.PlayMakerEditor.FsmEditorUtility.GetActionLabel(HutongGames.PlayMaker.FsmStateAction)' is obsolete: `Use Labels.GetActionLabel instead.'


So it's clearly linked in some way to the PlayMaker Utils stuff that is imported when I import Array Maker.


jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Hi,

 Yeah, ok I see, I need to update the package of ArrayMaker to use the latest PlayMaker Utils.

Can you import ArrayMaker from the ecosystem again, let me know how it goes, PlayMaker Utils files should now be up to date and not giving you any errors.

 Bye,

 Jean

NateGallardo

  • Playmaker Newbie
  • *
  • Posts: 31
    • View Profile
Re: Updated to 1.8.2: PlayMakerEditorUtils.cs, '...is obsolete' compile error
« Reply #6 on: September 02, 2016, 04:26:43 AM »
Hi Jean,

I updated Arraymaker, and removed and updated Playmaker, but I still have the same two errors.


jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Updated to 1.8.2: PlayMakerEditorUtils.cs, '...is obsolete' compile error
« Reply #7 on: September 02, 2016, 07:17:30 AM »
Hi,

 uhm... let me run some tests locally, I'll get back to you on this.

 Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Updated to 1.8.2: PlayMakerEditorUtils.cs, '...is obsolete' compile error
« Reply #8 on: September 27, 2016, 12:15:21 AM »
Hi,

 I think I discovered something with 5.4 and PlayMaker, it seems PlayMaker can't setup the Player settings properly to include some Scripting Define Symbols.

 Can you double check that your Scripting Define Symbols are filled in with Playmaker entries?

Bye,

 Jean

NateGallardo

  • Playmaker Newbie
  • *
  • Posts: 31
    • View Profile
Hi Jean,

Attached is what I currently have in my Scripting Define Symbols.

Hope that helps :)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Updated to 1.8.2: PlayMakerEditorUtils.cs, '...is obsolete' compile error
« Reply #10 on: October 10, 2016, 02:21:42 AM »
Hi,

 Ok, then you are fine on that aspect.

Do you still get this issue?

 Bye,

 Jean