playMaker

Author Topic: Get Material work strange  (Read 1973 times)

zelmund

  • Playmaker Newbie
  • *
  • Posts: 18
    • View Profile
Get Material work strange
« on: February 15, 2017, 03:29:24 AM »
Get shared material in "Get Material" action seems work not correct if i set material index more then 0.
with 0 is fine, material become shared, but if i set 1, then shared material is not shared anymore. it create instance and thats it.
is that bug or i something dont undrstand with unity?

zelmund

  • Playmaker Newbie
  • *
  • Posts: 18
    • View Profile
Re: Get Material work strange
« Reply #1 on: February 15, 2017, 03:42:21 AM »
omg. sry for repost but i found my post here on forums few years ago.
and this bug still there

http://hutonggames.com/playmakerforum/index.php?topic=9586.0

steps for repeat:

1. create object (cube/sphere/capsule)
2. make materials size 2
3. create 2 materails with different names and place them on created object
4. create fsm on sphere (or where you want)
5. create state in fsm
6. go to action browser, find and place get material
7. set shared material
8. set index 1
9. hit play and watch value status in variables section

and pls, fix this small problem, because i cant rewrite code everytime i upgrade playmaker
tool is great, its complicated and have nice upgrades, but 2 years and still...
« Last Edit: February 15, 2017, 03:50:06 AM by zelmund »

zelmund

  • Playmaker Newbie
  • *
  • Posts: 18
    • View Profile
Re: Get Material work strange
« Reply #2 on: February 16, 2017, 12:30:22 AM »
seems our fix not working anymore too  :-\

any advice on that?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14316
  • Official Playmaker Support
    • View Profile
Re: Get Material work strange
« Reply #3 on: April 13, 2017, 12:42:42 AM »
Hi,

 I can have a look, but I need a repro case :)

 Bye,

 Jean