Author Topic: Difficulty with Playmaker in 2017.2 / 2017.1[SOLVED]  (Read 860 times)


  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Difficulty with Playmaker in 2017.2 / 2017.1[SOLVED]
« on: November 21, 2017, 05:54:24 PM »

I am having many errors.

When I put an FSM on an object and expand it in the inspector there is nothing. I get this error on the console:

MissingMethodException: Method not found: 'UnityEngine.Texture2D.LoadImage'.
HutongGames.PlayMakerEditor.FsmEditorStyles.InitCommon () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmEditorStyles.cs:302)
HutongGames.PlayMakerEditor.FsmEditorStyles.Init () (at c:/Users/Alex/Documents/Unity/Playmaker/Projects/Playmaker.source.unity/Assets/PlayMaker/Editor/Classes/FsmEditorStyles.cs:275)
FsmComponentInspector.OnInspectorGUI () (at Assets/PlayMaker/Editor/FsmComponentInspector.cs:63)
UnityEditor.InspectorWindow.DrawEditor (UnityEditor.Editor[] editors, Int32 editorIndex, Boolean rebuildOptimizedGUIBlock, System.Boolean& showImportedObjectBarNext, UnityEngine.Rect& importedObjectBarRect) (at C:/buildslave/unity/build/Editor/Mono/Inspector/InspectorWindow.cs:1240)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Also, strange behavior in the hierarchy pane. I have tried this on Unity 2017.1 and 2017.2_0f3. I have playmaker 1.8.5. I sent a PM to Alex requesting access to the beta version but I do not have it yet. Is this issue solved by the beta?

Thank you for any help!
« Last Edit: January 11, 2018, 11:46:58 PM by jeanfabre »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3630
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Difficulty with Playmaker in 2017.2 / 2017.1
« Reply #1 on: November 21, 2017, 11:25:23 PM »
There is a Unity bug where sometimes the Unity API Updater fails to update the project.

There is another Unity bug where Unity imports the last version of an asset downloaded, ignoring whether it's the right package for the version of Unity you're currently running.

Either way, the fix is to explicitly download Playmaker again, while running the version of Unity you want to use it with. So in Unity, go to Asset Store then Download Manager and download Playmaker again. Import and install.

Let me know if that fixes the issue for you.