playMaker

Author Topic: Set FSM int isn't working as part of a prefab[SOLVED]  (Read 773 times)

PalmParadise

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Set FSM int isn't working as part of a prefab[SOLVED]
« on: January 23, 2018, 06:56:38 PM »
So I was working on an ammo pack which would give the player an extra 25 shots when they walked onto it. I've got it working with the initial object I created. No problems at all. However, after I dragged it into my prefabs folder so that I could spawn it with my random spawning system, and tested that by pulling it out into the world, I noticed that these new instances of my objects weren't working. The FSMs are exactly the same, everything is in order. However, only the initial item that I created works. I run over the original, 25 ammo gets added to the player's supply. I run over the prefab instances, nothing.

Forgot to mention that when I change the settings of the FSM in the prefab window after selecting it in my folder that it does change the properties of the original object that I've not removed from the scene.
« Last Edit: January 31, 2018, 10:55:15 PM by jeanfabre »

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 5078
    • View Profile
    • jinxtergames
Re: Set FSM int isn't working as part of a prefab
« Reply #1 on: January 24, 2018, 12:46:26 AM »
Hi.
Prefabs can not communicate with scene objects, this is a unity limitation.

Here are some ways that you can connect prefabs to others scene objects :